Problèmes avec le fichier d'installation de Windows 10 ESD-ISO [Résolu/Fermé]

Signaler
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021
-
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021
-
Bonjour,
Pour installer Windows 10 sur un PC en multiboot, sur un DD de 3To formaté en GPT, j'avais déjà essuyé un échec avec un DVD live réalisé à l'aide de l'outil proposé par Microsoft. J'ai donc essayé une autre méthode et téléchargé le fichier ISO (x64) mis à disposition par Microsoft, à l'aide du même outil (mais en m'arrêtant avant la gravure du DVD). Ensuite, j'ai voulu créer une clé USB bootable, pour procéder à l'installation, mais là surprise : impossible de copier le contenu du fichier ISO, que je le fasse par ligne de commandes, ou bien par un petit programme qui s'appelle « Rufus ». Comme ce dernier offre un log de l'opération, je m'aperçois alors que c'est le fichier ISO de MS qui est estimé corrompu, défaillant...enfin pourri, et je comprends mieux pourquoi ma première tentative d'installation avait échoué :
Rufus version: 2.2.668
Windows version: Windows 10 64-bit
Syslinux versions: 4.07/2013-07-25, 6.03/2014-10-06
Grub versions: 0.4.6a, 2.02~beta2
Locale ID: 0x040C
Found USB device 'Generic USB CF Reader USB Device' (????:????)
Device eliminated because it appears to contain no media
Found USB device 'Generic USB SM Reader USB Device' (????:????)
Device eliminated because it appears to contain no media
Found USB 1.1 device 'Generic USB SD Reader USB Device' (058F:9360)
Device eliminated because it appears to contain no media
Found USB device 'Generic USB MS Reader USB Device' (????:????)
Device eliminated because it appears to contain no media
Found USB 2.0 device 'SanDisk Cruzer Edge USB Device' (0781:556B)
Found USB 2.0 device 'SanDisk Cruzer Blade USB Device' (0781:5567)
Removing K: from the list: This is the disk from which Rufus is running!
1 device found
Disk type: Removable, Sector Size: 512 bytes
Cylinders: 973, TracksPerCylinder: 255, SectorsPerTrack: 63
Partition type: MBR, NB Partitions: 1
Disk ID: 0x00000000
Drive has a Windows 7 Master Boot Record
Partition 1:
Type: FAT32 (0x0b)
Size: 7.5 GB (8002732032 bytes)
Start Sector: 2048, Boot: Yes, Recognized: Yes
Checking for Rufus updates...
Checking release channel...
No new release version found.
Scanning image...
libcdio: fread (): Invalid argument
libcdio: fread (): Invalid argument
'F:\Stockage commun\Informatique\Programmes\Windows 10 Pro\Windows.iso' doesn't look like an ISO image
read_sectors: Read error [0x0000045D] Impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S.
Read: 0, Expected: 512
StartSector: 0x00000000, nSectors: 0x1, SectorSize: 0x200
Image does not have an x86 Master Boot Record
Failed to scan image
Pourtant, compte tenu du nombre vraisemblable de téléchargements qui ont été opérés à partir du site de MS, je reste un peu incrédule devant l'hypothèse d'une telle bourde, dont je devrais, me semble-t-il, déjà avoir entendu parler si elle était réelle.
Quelqu'un aurait-il eu une expérience semblable ?

2 réponses

Messages postés
32511
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
23 juillet 2021
7 826
Bonjour,

J'ai téléchargé (avec l'outils microsoft) et utilisé 2 iso, une w10 Pro (avec 32 et 64 bits) et une W10 Famille (aussi 32 et 64 bits).

Pour mettre l'iso sur une clé usb, j'ai juste ouvert l'iso (sur 8.1 c'est natif dans windows) et réalisé un copier/coller sur une clé usb et elle fonctionnait en boot.

Je n'ai par contre pas testé un boot uefi/gpt.

Mais avant de faire une installation depuis une clé à tu déjà effectué le maj W10 qu'il est indispensable avant une installation complète ?

cdlt

Un étranger, c'est un ami qu'on n'a pas encore rencontré.
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021
1
Merci pour ta réponse, jee pee, et bravo pour ta rapidité!
Le DVD que j'avais gravé bootait correctement aussi, mais c'est au moment de l'installation que ça bugait.
Effectivement, j'ai effectué des douzaines de MàJ, en tant qu'insider (dans le fast ring), et l'OS que j'utilise pour ces messages est déjà un W10, upgradé de cette manière à partir d'un W7 Ultimate. J'en ai également un autre (W10) qui tourne sur un laptop HP, upgradé à partir d'un W8,1. Mais je voulais utiliser la pleine capacité d'un disque dur de 3 To installé en troisième position sur le PC, et pour cette raison, le passer en GPT. Or, on ne peut pas restaurer, à ce que je crois savoir, une image système faite à partir d'un disque MBR sur un disque GPT. J'ai déjà essayé et le disque se remet automatiquement dans la configuration d'origine correspondant à l'image. Pour cette raison, j'avais décidé de repartir de zéro sur ce disque (tout le reste est sauvegardé sur un disque externe), de le cleaner et le convertir en GPT, puis installer dessus tranquillement un Windows 10 tout neuf. Cela aurait présenté l'avantage, outre le gain d'espace dans mon DD, de me permettre d'expérimenter un OS aussi léger que possible, sur lequel j'envisageais de n'installer que le minimum de programmes tiers, pour éviter dans la mesure du possible de le surcharger, comme j'ai un peu tendance à le faire.
Mais il y a peut-être d'autres manières de procéder pour parvenir au même résultat. Simplement, à chaque fois que j'effectue des manipes un peu lourdes sur les systèmes du PC, je cours le risque de détruire le multiboot et d'avoir à le reconstruire.
Salutations cordiales.
Messages postés
32511
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
23 juillet 2021
7 826 >
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021

Quand on veut installer un disque en gpt, il faut booter en uefi sur la clé (ou le dvd)

Cela veut dire que le bios doit être paramétré sur uefi et qu'il faut passer par le menu de boot pour booter sur la clé en uefi. Logiquement dans le menu de boot tu dois voir ta clé listée 2 fois, une fois en uefi et une fois en legacy (ou mbr).

voir des explications détaillées : https://lecrabeinfo.net/installer-windows-7-8-10-mode-uefi.html#demarrer-le-dvd-dinstallation-en-mode-uefi
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021
1 >
Messages postés
32511
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
23 juillet 2021

Pardon à Jee Pee et à Luckydu43 de ma réponse tardive: je n'étais pas sur ce problème dans la journée, et viens seulement de le reprendre. Du reste, il me semble résolu. Il se pourrait en effet que les logs de "Rufus" m'aient induit en erreur, car je crois que l'installation est en train de se faire gentiment avec le DVD gravé en premier lieu. J'avais bien pris toutes les précautions pour démarrer en EFI, mais j'avais seulement oublié qu'il me fallait déconnecter les deux autres disques durs du PC, faute de quoi il refuse toute installation sous des prétextes variables. Je l'avais déjà antérieurement constaté, mais ça ne m'était pas revenu au moment opportun.
Ma carte-mère n'est pas très bavarde, et ne me propose dans le BIOS qu'une option: le choix entre EFI, NON-EFI, et AUTO pour le démarrage des CD/DVD, mais c'est suffisant.
Merci pour vos avis pertinents, qui m'ont aidé à éliminer des causes improbables à mon problème.
Salutations cordiales.
Messages postés
3452
Date d'inscription
vendredi 9 janvier 2015
Statut
Membre
Dernière intervention
2 juillet 2021
731
Bonsoir,

"read_sectors: Read error [0x0000045D] Impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S. " => Avez-vous vérifié l'intégrité de votre disque dur ? De votre clé usb ? Un bon coup de chkdsk /F /V /R /B est très efficace pour réparer une erreur d'E/S.

Personnellement, j'ai monté une VM de Windows 10 (par dessus mon Windows 10), grâce à une iso téléchargée par mediacreationtool et l'image s'est très bien montée et installée...

Et une erreur d'intégrité de l'iso lors du téléchargement est une possibilité... rare, mais possible.

Après, je ne comprends pas pourquoi il refuserait l'installation. Le dualboot le gêne peut-être ?! Même principe... un collègue l'a fait sans problème...

En espérant avoir levé quelques idées...

Bonne soirée !
Messages postés
47
Date d'inscription
jeudi 14 novembre 2013
Statut
Membre
Dernière intervention
17 avril 2021
1
Pardon à Jee Pee et à Luckydu43 de ma réponse tardive: je n'étais pas sur ce problème dans la journée, et viens seulement de le reprendre. Du reste, il me semble résolu. Il se pourrait en effet que les logs de "Rufus" m'aient induit en erreur, car je crois que l'installation est en train de se faire gentiment avec le DVD gravé en premier lieu. J'avais bien pris toutes les précautions pour démarrer en EFI, mais j'avais seulement oublié qu'il me fallait déconnecter les deux autres disques durs du PC, faute de quoi il refuse toute installation sous des prétextes variables. Je l'avais déjà antérieurement constaté, mais ça ne m'était pas revenu au moment opportun.
Merci pour vos avis pertinents, qui m'ont aidé à éliminer des causes improbables à mon problème.
Salutations cordiales.