Formule applicable à plusieurs colonnes variables

Fermé
Signaler
-
Messages postés
24269
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 janvier 2022
-
Bonjour,


Je souhaite faciliter une manipulation que je fais régulièrement sur Excel. Je vais passer par un exemple pour que ce soit plus compréhensible.

Calcul compliqué = [A1 * (E1 + D1/2 - B1) + A2 * (E2 + D2/2 - B2) + A3 * (E3 + D3/2 - B3)]

Voilà, on voit que c'est toujours la même formule [Ai * (Ei + Di/2 - Bi) mais je suis obligée de la taper...

Est-ce qu'il n'y aurait pas une façon plus simple de procéder? Du genre de pouvoir appliquer une formule à une plage et de les sommer?

Calcul simple =somme {A1:A3 * (E1:E3 + D1:D3/2 - B1:B3)}... C'est un exemple ça ne marche pas en vrai.

Merci pour vos réponses!


Didi

2 réponses

Messages postés
13341
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 janvier 2022
2 325
Bonjour

Tu peux passer par la fonction indirect pour bâtir une référence variable

=INDIRECT("A" & ligne()) * (INDIRECT("E" & ligne()) + INDIRECT("D" & ligne())/2 - INDIRECT("B" & ligne())) + INDIRECT("A" & ligne()+1) * (INDIRECT("E" & ligne()+1) + INDIRECT("D" & ligne()+1)/2 - INDIRECT("B" & ligne()+1)) + INDIRECT("A" & ligne()+2) * (INDIRECT("E" & ligne()+2) + INDIRECT("D" & ligne()+2)/2 - INDIRECT("B" & ligne()+2))

ligne() est le n° de la ligne courante; la formule devra donc être placée dans une cellule de la ligne 1 sinon modifier le formule pour retomber sur 1 (par exemple si la formule est en ligne 3 elle commencera par INDIRECT("A" & ligne()-2)

Cdlmnt
Via
0
Messages postés
24269
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 janvier 2022
7 026
Bonjour,

Tu peux utiliser sommeprod() qui te fait la somme des produits des éléments d'une matrice :
=SOMMEPROD(A1:A5;E1:E5+D1:D5/2-B1:B5)

eric

En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0