Récupérer contenu d'une cellule pour le mettre dans une formule

[Fermé]
Signaler
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015
-
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015
-
Bonjour,

Je suis bloquée.
Voici mon problème

Dans la colonne A j'ai des numéros de dossier
Dans la colonne B j'ai les liens hypertexte menant aux dossiers(ex : PA vierge)
Dans la colonne C j'ai des états qui s'affiche en fonction de la formule suivante :

=SI('[PA vierge.xls]Aktionsplan'!$B$25="oui";"soldé";"")

Je souhaiterais trouver une formule qui fasse le lien avec le contenu de ma colonne B au lieu de [PA vierge.xls].

Merci par avance

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
537
Bonjour,

Essaie avec
=SI(INDIRECT("'[" & B3 & ".xls]Aktionplan'!$B$25")="oui";"soldé";"")

A+
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015

Bonjour,

Merci pour la formule.
J'ai un problème quand je la mets sous Excel, l'erreur #REF! apparaît.
Quand j'évalue l'erreur, j'obtiens :

=SI(#REF! = "oui";"soldé";"")

Je ne sais pas comment faire pour que la formule soit acceptée.

Merci
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
537 >
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015

Bonjour,

Je vois deux possibilités :

- le première c'est que le nom de la feuille est mal orthographié (Aktionplan au lieu de Aktionsplan)

- la deuxième, c'est que le classeur PA vierge.xls n'est pas ouvert.

A+
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015
>
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016

Bonjour,

J'ai réussi.
Le soucis est que la fonction INDIRECT n'est pas adaptée car je souhaite avoir les informations même quand le classeur PA vierge.xls est fermé...
Une idée ?

Merci
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
537
Bonjour,

Une solution proposée par Laurent Longre :
http://www.excelabo.net/excel/indirect_classeur_ferme
Function RECUP(Fichier As String, Feuille As String, _
Ligne As Long, Col As Integer)
With CreateObject("Excel.Application").Workbooks.Open(Fichier)
RECUP = .Worksheets(Feuille).Cells(Ligne, Col)
.Close False
End With
End Function


Avec le chemin complet dans la cellule A1 :
C:\Users\Documents\PA vierge.xls

Et la formule :
=RECUP(A1;"Aktionsplan";25;2)

A+
Messages postés
22
Date d'inscription
mardi 26 mai 2015
Statut
Membre
Dernière intervention
17 juin 2015

Bonjour,

Je suis désolée pour le retard.
La fonction marche très bien.
Par contre si j'effectue des mises à jour sur le classeur PA vierge, je ne les retrouve pas sur le classeur qui me sert de base de donnée.
Comment faire pour que les mises à jour se fasse aussi sur mon classeur qui me sert de base de donnée?

Merci

Zambrya