Formule conditionnelle

Fermé
Dulinski - 21 avril 2015 à 08:41
Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 - 21 avril 2015 à 12:57
Bonjour,je voudrais savoir quelle serait la formule sous Excel
pour avoir une valeur 1 ou 0
je détaille :
colonne f4 : GIR1
f5: GIR2.... etc jusqu'à GIR6
colonne g: GIR1
colonne h:GIR2
etc ... jusqu'à GIR6
donc je voudrais qu a chaque fois que GIR 1 apparaît en f,g passe à 1 et les autres colonnes passent à 0 et pareil sur chaque GIR.
Merci d avance.

3 réponses

Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 5 034
Modifié par Mike-31 le 21/04/2015 à 09:35
Bonjour,

Il t a été demandé un exemple de fichier annoté que l'on comprenne quelle formule adapter. Si tu souhaite vraiment cette aide joint un bout de fichier à partir de ce lien et évite la multiplication de tes posts que l'on s' y retrouve
https://www.cjoint.com/
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Excel-worker Messages postés 589 Date d'inscription mardi 7 avril 2015 Statut Membre Dernière intervention 23 juillet 2015 58
Modifié par Excel-worker le 21/04/2015 à 08:50
Bonjour,

Un lien pour voir à quoi ressemble ton fichier est appréciable, met également quelques commentaires pour qu'on voit ce que tu veux.

Tu peux l'héberger ici : www.cjoint.com


Cordialement
0
Je ne peut pas te l envoyer avant midi la je suis au taf cdlt
0
Il est vrai que g oublier de préciser que GIR1 GIR2 etc.... c'est du texte
0
J ai mis cette formule:
=SI (F4="GIR1";"0";SI (F4="";"";si (F4 <>"GIR1";"1";)))
ça me met bien le 1 dans g4 mais par contre si je reprend la formule dans g5 ,on va dire qu il y a la valeur GIR2 ,ça me met pas 0.
0
http://cjoint.com/?EDvm7EBKBtY
0
Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 5 034
Modifié par Mike-31 le 21/04/2015 à 12:58
Re,

déjà on y voit plus clair, tes listes de validation ne fonctionnent pas parce que les saisis dans ta feuille "Tables" D2:D7 ne sont pas identiques avec les cellules de référence G3:L3 onglet "GIR"
pour éviter ces problèmes change le paramétrage de tes validations en onglet GIR colonne F par cette formule
=$G$3:$L$3
ensuite la formule en G4 doit certainement être =SI(F4=$G$3;1;0)

à incrémenter vers le bas et adapter dans les colonnes de droite

que vient faire cette mise en forme conditionnelle qui vient noircir la plage G4:L4
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0