Pas de connexion wifi entre eee pc et freebox - linux mint 17.1 [Résolu/Fermé]

Signaler
-
Messages postés
29276
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
-
Bonjour,
Avec cet eee pc sous linux mint 17.1, j'avais pu me connecter sans problème avec une Livebox. Je souhaite maintenant me connecter à une Freebox et ça ne fonctionne pas... J'ai suivi le tuto suivant :
https://www.commentcamarche.net/faq/11210-configurer-le-wifi-sous-linux
A continuation vous trouverez les infos demandées en cas de problème. J'étais connecté en filaire quand j'ai pris ces infos.
Merci d'avance pour votre aide !!
----------------
/sbin/iwconfig
eth0      no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Moncorps"
Mode:Managed Access Point: Not-Associated Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

---------------
/sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 54:04:a6:29:0c:96  
inet adr:192.168.0.14 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::5604:a6ff:fe29:c96/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:1625 erreurs:0 :0 overruns:0 frame:0
TX packets:2076 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 lg file transmission:1000
Octets reçus:644086 (644.0 KB) Octets transmis:265469 (265.4 KB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:384 erreurs:0 :0 overruns:0 frame:0
TX packets:384 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:47089 (47.0 KB) Octets transmis:47089 (47.0 KB)

wlan0 Link encap:Ethernet HWaddr 74:2f:68:4d:e9:4c
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

wlan0:avahi Link encap:Ethernet HWaddr 74:2f:68:4d:e9:4c
inet adr:169.254.8.7 Bcast:169.254.255.255 Masque:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1

----------------
/sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.0.254 0.0.0.0 UG 0 0 0 eth0
0.0.0.0 0.0.0.0 0.0.0.0 U 1003 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
192.168.0.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

-----------------
cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

-----------------
nslookup www.google.fr
Server:  127.0.1.1
Address: 127.0.1.1#53

Non-authoritative answer:
Name: www.google.fr
Address: 74.125.24.94

--------------------
ping -c2 www.google.fr
PING www.google.fr (216.58.211.163) 56(84) bytes of data.
64 bytes from dub08s01-in-f3.1e100.net (216.58.211.163): icmp_seq=1 ttl=53 time=45.7 ms
64 bytes from dub08s01-in-f3.1e100.net (216.58.211.163): icmp_seq=2 ttl=53 time=45.4 ms

--- www.google.fr ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 45.407/45.562/45.717/0.155 ms

-------------------------

6 réponses

Messages postés
29276
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
6 914
Si tu es parvenu à te connecter à une livebox, ta carte wifi fonctionne correctement. C'est donc un problème de paramétrage au niveau du point d'accès :

1) soit sous linux, car tu as par exemple mal tapé le mot de passe ;
2) soit côté freebox, car un filtrage quelconque, par exemple sur l'adresse MAC, est mis en place

Contrairement aux livebox, bbox et sfrbox, il n'y a pas par défaut de filtrage MAC opéré par une freebox. Je pense donc que la première explication est la plus probable.

Les résultats que tu nous reportes laisse penser que de toute façon, tout marche ici correctement (tu parviens à résoudre et pinger google). Peux-tu nous indiquer si "Moncorps" correspondait au wifi de ta freebox ?

Confirme-nous également avec
iwlist wlan0 scan
que le réseau wifi auquel tu tentes de te connecter est bien visible.

Bonne chance
Merci pour ces infos.

J'étais connecté en filaire quand j'ai fait les manips, je pense que c'est pour ça que j'avais des retours de ping. J'ai refait à l'instant les manips sans la connexion filaire, je mets les résultats à continuation en fin de message, y compris le résultat de "iwlist wlan0 scan". Du coup je n'ai pas de retour des pings, iwlist ne trouve pas de résultat, je ne vois plus "Moncorps" avec iwconfig.

"Moncorps" est bien le nom du wifi auquel j'essaie de me connecter.

En ce qui concerne le filtrage MAC, je pense effectivement qu'il n'est pas actif car des amis se sont connectés sans problème avec des téléphones portables avec le mot de passe que je leur ai donné. D'ailleurs je ne trouve pas d'option filtrage MAC dans l'interface de gestion de la Freebox...

Peut être un autre indice :
Au démarrage de linux mint, pendant l'affichage du logo et avant apparition du bureau, j'ai un message "waiting for network configuration" même avec le réseau filaire branché, puis "waiting 60 more seconds for network configuration". A l'ouverture du bureau, network manager n'apparait pas tout de suite, comme avant que je fasse les manips de commentcamarche.net.
J'ai également essayé de me connecter en wifi avec une clé wifi externe, et là miracle je peux me connecter au wifi Moncorps sans problème. Du coup je me dis qu'il y a bien un problème avec le dispositif wifi intégré, comme une histoire de driver. Je continue les recherches... Sans la clé wifi externe, network manager indique "Wifi non géré". Avec la clé wifi externe, je vois en plus que c'est "Qualcomm Atheros AW-NE785/AW-NE785H 802.1bgn Wireless full or Half-size Mini PCIe Card" qui n'est pas géré.
Je me demande aussi si wlan0:avahi n'a pas quelque chose à voir dans cette histoire...

---------------------
/sbin/iwconfig
eth0      no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

---------------------
/sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 54:04:a6:29:0c:96  
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:1282 erreurs:0 :0 overruns:0 frame:0
TX packets:1317 errors:0 dropped:0 overruns:0 carrier:2
collisions:0 lg file transmission:1000
Octets reçus:972847 (972.8 KB) Octets transmis:165634 (165.6 KB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:974 erreurs:0 :0 overruns:0 frame:0
TX packets:974 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:106639 (106.6 KB) Octets transmis:106639 (106.6 KB)

wlan0 Link encap:Ethernet HWaddr 74:2f:68:4d:e9:4c
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

wlan0:avahi Link encap:Ethernet HWaddr 74:2f:68:4d:e9:4c
inet adr:169.254.8.7 Bcast:169.254.255.255 Masque:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1


--------------------------
/sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 0.0.0.0 0.0.0.0 U 1003 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0

--------------------------
cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

--------------------------
nslookup www.google.fr
;; connection timed out; no servers could be reached

--------------------------
iwlist wlan0 scan
wlan0     No scan results

--------------------------
ping -c2 www.google.fr
ping: unknown host www.google.fr

--------------------------
Bonjour,
Tu as vérifié que ta carte wifi n'est pas simplement désactivée (Fn+F2) ? Si c'est le cas, le voyant est éteint.
Si la carte a fonctionné avec une livebox, je ne vois que cette explication à ton problème.
Bonjour jns55,
oui la carte wifi est activée. Quand j'ai fait Fn+F2, j'ai vu dans Network Manager le wifi avec un interrupteur sur 0. En faisant Fn+F2 à nouveau, il est à nouveau indiqué "Wifi non géré".
Messages postés
29276
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
6 914
Dans ton cas le fait que
iwlist wlan0
n'affiche pas de résultat n'est pas bon signe. Ça sent la carte wifi mal installée ou un network manager mal installé.

Pour commencer assure-toi que seul network-manager est installé (pas wicd, car je ne pense pas que les deux puissent marcher simultanément).

Ce qui est surprenant c'est que tu arrivais à te connecter à une livebox par le passé. Est-ce toujours le cas, parviens-tu as te connecter à d'autres réseau wifi ? S'agit-il d'un réseau wifi caché ?

Indique-nous également le modèle exact de ta carte wifi :

lspci


Bonne chance
Essaie aussi de lancer une session live avec ton media d'installation : si tu parviens à te connecter, c'est ta config qui est corrompue, si tu n'y parviens pas... ça pourrait vouloir dire que la carte wifi a du plomb dans l'aile.
@mamiemando :

apt-cache search wicd | grep wicd renvoie des résultats, mais
dpkg -l | grep wicd ne renvoie rien, donc je pense que wicd n'est pas installé.

Je n'ai pas pu essayer de me connecter à un autre réseau wifi.
Quand j'essaie de me connecter avec la clé wifi externe, je n'ai pas besoin de chercher un réseau caché pour trouver le bon.

lspci renvoie :
01:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)


@jns55 :
En lançant linux mint à partir de l'USB que j'ai utilisé à l'installation, j'arrive à me connecter au wifi sans problème, le réseau n'est pas caché. J'en déduis que la carte wifi interne fonctionne bien et que c'est un problème de mon linux mint installé.

@tous les 2 :
J'ai modifié /etc/network/interfaces :

# interfaces(5) file used by ifup(8) and ifdown(8) 
auto lo
iface lo inet loopback

#auto wlan0
#iface wlan0 inet dhcp
# wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


Du coup, après un redémarrage, ça fonctionne, j'arrive à me connecter en wifi avec la carte interne. Par acquis de conscience, j'ai essayé d'enlever la mise en commentaires des 3 lignes correspondantes à wlan0, je suis revenu à la situation antérieure (waiting for network configuration au démarrage, pas de connexion possible avec la carte wifi interne). Je laisse donc les 3 lignes en commentaires... J'ai l'impression que cette solution n'est pas très élégante, mais le problème est résolu. Merci en tout cas pour votre aide !!

Je me suis aussi inspiré des discussions suivantes :
https://forums.commentcamarche.net/forum/affich-10980697-network-manager-est-installe-mais-introuvable -> merci mamiemando à nouveau
http://doc.ubuntu-fr.org/wifi_atheros_ar9285 -> j'ai utilisé la commande
echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf
Messages postés
29276
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
6 914
Bonsoir Erwann,

Pour résumer la solution :

- oui il ne faut rien configurer à la main dans les fichiers de configuration si tu passes par network manager comme expliqué en gras dans le tutoriel :-)
https://www.commentcamarche.net/faq/11210-configurer-le-wifi-sous-linux#troisieme-etape-configurer-la-carte

- pour la carte, effectivement ta démarche était la bonne : il fallait en effet (une fois la carte identifiée) voir s'il n'y avait pas un point de configuration particulier à effectuer comme spécifié dans la documentation officielle :-)
http://doc.ubuntu-fr.org/wifi_atheros_ar9285

Bonne continuation