Convertir une date de naissance en année

Fermé
Signaler
Messages postés
1
Date d'inscription
lundi 23 mars 2015
Statut
Membre
Dernière intervention
23 mars 2015
-
Messages postés
17825
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 janvier 2022
-
Bonjour à Tous
Je souhaite convertir plusieurs dates de naissance (date mois année) en age (ans). Exemple 15/07/1995 ferait quel age au 23/03/2015?
Merci à tous pour votre aide. J'utilise Excel 2007.
A voir également:

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Bonjour,

Avec la date de naissance en A1 :
=DATEDIF(A1;AUJOURDHUI();"y") & " an(s) " & DATEDIF(A1;AUJOURDHUI();"ym") & " mois "  & DATEDIF(A1;AUJOURDHUI();"md") & " jour(s)"

A+
1
Messages postés
17825
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 janvier 2022
4 914
Bonjour,
si en A1 tu as la date de naissance et en B1 la date tampon
=SI(B1-A1;TEXTE(DATEDIF(A1;B1;"y");"[>1]0"" ans "";[>]""1 an "";")&TEXTE(DATEDIF(A1;B1;"ym");"[>]0"" mois "";")&SI(B1-A1;TEXTE(DATEDIF(A1;B1;"md");"[>1]0"" jours "";[>]""1 jour "";")))

ou par rapport à aujourd'hui
=SI(A1="";"";SI(AUJOURDHUI()-A1;TEXTE(DATEDIF(A1;AUJOURDHUI();"y");"[>1]0"" ans "";[>]""1 an "";")&TEXTE(DATEDIF(A1;AUJOURDHUI();"ym");"[>]0"" mois "";")&SI(AUJOURDHUI()-A1;TEXTE(DATEDIF(A1;AUJOURDHUI();"md");"[>1]0"" jours "";[>]""1 jour "";"))))

ces formules prennent en compte le pluriel des années et jours et n'affichent que les données supérieures ou égale à 1 an ou mois ou jour
0