Lancer batch avant fermeture Windows [Résolu/Fermé]

Signaler
Messages postés
40
Date d'inscription
jeudi 10 mai 2012
Statut
Membre
Dernière intervention
11 août 2015
-
Messages postés
40
Date d'inscription
jeudi 10 mai 2012
Statut
Membre
Dernière intervention
11 août 2015
-
Bonjour à tous,

Je souhaite de nouveau faire appel à vos conaissances car là je suis bloqué!

J'ai créé un script (.bat, qui fonctionne aussi en .cmd) que je souhaite lancer avant la fermeture de session Windows... (Mon script marche parfaitement)
Pour çà, j'ai utilisé le task scheduler ; faire un click droit > run sur ma tâche schedulée lance parfaitement le script aussi.
Par contre, lorsque je fais un Log Off, le script ne se lance pas! Comme si Windows ne lui laissait pas le temps de se compiler avant de se fermer...

En plus, mon script va tapper dans les clés de registre de l'utilisateur donc s'il n'est pas loggué, çà ne marche plus!

Je voudrais donc qu'il y ait un délai de 10 secondes entre le moment où j'appui sur "Start>Shutdown>Log Off" et le moment où Windows se ferme...

Sauriez-vous comment faire??

Merci d'avance pour vos réponses...

2 réponses

Messages postés
25796
Date d'inscription
lundi 4 février 2008
Statut
Membre
Dernière intervention
28 mars 2021
8 842
Salut,

Tu peux essayer de créer un raccourci sur le bureau pour éteindre l'ordinateur en lui mettant un certains temps avant la fermeture.

Exemple pour dix secondes avant la fermeture de Windows.

Clic droit sur le bureau et ===> Nouveau ===> Raccourci

Remplir le champs avec :

C:\Windows\System32\shutdown.exe -s -t 10

Pour terminer, mettre le nom du raccourci.
Exemple Éteindre l'ordinateur.

Il ne restera plus qu'à changer l'icône en faisant un clic droit sur le raccourci/propriétés/onglet raccourci et changer l'icône.
Messages postés
40
Date d'inscription
jeudi 10 mai 2012
Statut
Membre
Dernière intervention
11 août 2015

Bonjour Papounet,

Merci d'avoir répondu au sujet mais celà ne me convient pas :
Dans mon cas, je ne souhaite pas eteindre la station mais juste me délogger. la commande est donc
shutdown -l
et l'argument
-t 10
ne peut plus être utilisé.

De plus, celà ne m'aide pas à lancer le script avant le log off... Rajouter la ligne
shutdown -l
à la fin du script et l'éxecuter directement serait une idée ; mais je ne trouve pas çà propre et je ne vais pas adopter cette solution.

En revanche, j'ai trouvé une solution sur un autre sujet de discussion (je ne me rappelle plus de la source, je ne vais donc pas la citer) :

1°/ Copiez le script sous C:\Windows\System32\GroupPolicy\User\Scripts\Logoff
Et/ou alors sous C:\Windows\System32\GroupPolicy\Machine\Scripts\Shutdown selon vos besoins.
/!\ Il se peut que ces chemins n'existent pas ou ne soient pas entiers, ne les créez pas vous même, commencez par l'étape 2.

2°/ Sous Windows>Recherche ou un command prompt ou sous run (Windows + R), tapez gpedit.msc pour ouvrir le local group policy editor et allez sous User Configuration\Windows Settings\Scripts\ puis double cliquez sur Logoff (ou sur Computer Configuration\Windows Settings\Scripts\Shutdown toujours selon vos besoins). A partir de là, les dossiers seront automatiquement créés s'ils n'éxistaient pas encore.

3°/ cliquez sur Add puis Browse pour aller sélectionner votre fichier. La fenêtre Browse sera à l'endroit où vous avez collé votre script en 1°/.

Je ne comprend toujours pas pourquoi le scheduler de tâches ne fonctionne pas mais le principal est d'avoir une solution qui marche!

PS : j'ai fais les tests avec un fichier .cmd ; il faudrait tester si cela marche avec les autres extensions.