Forumle Excel 2007 - Conditions, soustraction, sélection cellule

Fermé
Signaler
Messages postés
16
Date d'inscription
vendredi 24 février 2012
Statut
Membre
Dernière intervention
29 août 2016
-
Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
-
Bonjour à tous,
J'aimerai faire une série de calcul sur Excel 2007 avec des conditions mais je n'y arrive pas J'espère que quelqu'un pourra m'aider.
voici le "problème" :
J'ai mis le tableau en image, pour que ce soit plus simple à comprendre



Ce que je voudrais faire, c'est qu'à chaque fois dans la colonne écart, Excel prenne la dernière colonne renseignée. Pour les 3 premiers mois, j'arrive à le faire en utilisant une petite formule avec SI, mais au delà je n'y arrive plus.

Dans l'exemple je n'ai rempli que les 2 premiers mois, mais l'idée est que lorsque je remplirai le mois 4 Excel fasse E2-B2 et le mois 5 F2-B2 et ainsi de suite. Seul l'écart entre le Mois 1 et le mois en cours m'importe.

En espérant avec été suffisamment claire et précise, si ce n'est pas le cas, n'hésitez pas à me demander des précisions.
Merci d'avance pour vos réponses.
Cdt,
Carole

2 réponses

Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
6 131
Bonjour
on peut voir ça de deux façons
(il semble que ce soit la première de ces deux qui vous intéresse)

les écarts entre le dernier et l'avant dernier, ce que vous obtenez avec:

=SI(NB.SI(B2:F2;"<>")<2;"";INDEX(B2:F2;;NB.SI(B2:F2;"<>"))-INDEX(B2:F2;;NB.SI(B2:F2;"<>")-1))

l'écart entre le premier en B et le dernier, et là, ce sera avec:

=SI(NB.SI(B2:F2;"<>")<2;"";INDEX(B2:F2;;NB.SI(B2:F2;"<>")-B2)

attention aux signes surtout les ;

la condition SI sert à éviter les affichages parasites (#N/A) quand B:F est vide ou ne comporte qu'une valeur en B

Note: ne fonctionne que si les valeurs en B:F sont bien contiguës, sans "trou"

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
486
Bonjour Karoa, bonjour Vaucluse,

"Seul l'écart entre le Mois 1 et le mois en cours m'importe. "

On peut aussi en G2
=SIERREUR(RECHERCHEH(999;$C2:$F2;1;1)-$B2;"")