Fonction Recherchev à partir d'un nom d'onglet - Macro/VBA?

Fermé
Vdpt
Messages postés
25
Date d'inscription
mercredi 5 juin 2013
Statut
Membre
Dernière intervention
2 juillet 2015
- 14 janv. 2015 à 11:50
DjiDji59430
Messages postés
3542
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
23 mai 2022
- 14 janv. 2015 à 12:36
Bonjour à tous,

je cherche à reproduire quelque chose que j'avais vu dans un fichier excel il y a quelques temps.

Je voudrais savoir s'il est possible de faire des recherches v en fonction du nom d'un onglet.

Exemple : Je possède un onglet A et un onglet B. En plus de cela j'ai un onglet récap.

Dans mon onglet récap, j'ai une colonne dont l'en tête s'appelle A, et une dont l'en tête s'appelle B.

Est il possible de faire une macro qui associe ma plage de recherche au nom de l'onglet désiré, mais qui fasse référence à une cellule pour la selection de cette plage, et ne m'oblige pas à aller selectionner la plage dans chacun des onglets.

ex : recherchev(Valeur,'ongletA'C:E,2,0)
Où 'ongletA' serait "inséré" dans la formule comme une réf de cellule (en l'occurence l'en tête de colonne dans mon cas) et non comme une selection de plage manuelle.

Je ne sais pas si j'ai été assez clair, n'hésitez pas si vs avez des questions!

Merci!!

2 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
14 janv. 2015 à 12:24
Bonjour
essayez avec:
=RECHERCHEV(valeur;INDIRECT("'"&A1&"'!C:E");2;0)
A1 contenant le nom de l'onglet

et si vos nom d'onglet ne contiennent ni blanc ni opérateur, un peu plus simplement (car les apostrophes encadrant le nom d'onglet ne sont plus utiles dans ce cas)
=RECHERCHEV(valeur;INDIRECT(A1&"!C:E");2;0)

crdlmnt
2
DjiDji59430
Messages postés
3542
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
23 mai 2022
532
14 janv. 2015 à 12:36
Bonjour,

Le meme en image

https://www.cjoint.com/c/EAomR2CXyA7
0