Problème afficher une image en Html 5 [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
mardi 16 décembre 2014
Statut
Membre
Dernière intervention
16 décembre 2014
-
 Misterui -
Depuis hier j'essai de développer en HTML 5, avec smultron (sur mac).
Voila j'ai suivie des tutos mais sa ne marche pas alors je ne sais plus quoi faire pourriez-vous m'aider??
<!DOCTYPE html>
<html>
    <head>
        <meta charset="utf-8" />
        <title>Titre</title>
    </head>

    <body>
    
    <body>

<div id="global">
<div id="contenu">
<h1>Bienvenue sur mon site !</h1>
<img src="images/rocker2.jpg" class="imageGauche"
alt="voici mon mini bmx">
<h2>ui</h2>
</html>
</div>
</div>

</body>
</html>



EDIT : Ajout des balises de code !

4 réponses

Un copain m'a résolu mon probleme sa venait de l'image.
Et merci les gars!!
Je viens de le voir oui avec figure j'ai put tester.
Cdlt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
29615
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 septembre 2020
2 798
Bonjour,

1 - Merci de bien vouloir utiliser la coloration syntaxique (les balises de code) lorsque tu postes du code sur le forum.
Explications disponibles ici :
https://codes-sources.commentcamarche.net/faq/10686-le-nouveau-codes-sources-comment-ca-marche#balises-code


2 - Tu dis :
mais sa ne marche pas

Ben.. oui.. mais heuu... mais ...encore ... ??
<<Ca ne marche pas... >> ... ne nous explique en rien ta difficulté ....
Si tu ne nous dis pas sur quoi tu bloques.. on aura du mal à t'aider ;-)


EDIT :
Déjà ;. dans ton code...tu semble avoir une balise <body> et une balise </html> en trop.. en plein milieu ...

Essayes comme ceci :

<!DOCTYPE html>
<html>
   <head>
      <meta charset="utf-8" />
      <title>Titre</title>
   </head>
<!-- DEBUT DU BODY -->
 <body>
  <div id="global">
    <div id="contenu">
       <h1>Bienvenue sur mon site !</h1>
       <img src="images/rocker2.jpg" class="imageGauche" alt="voici mon mini bmx">
       <h2>ui</h2>
    </div> <!-- fin du div "contenu" -->
  </div> <!-- fin du div "global" -->

 </body> <!-- fin du BODY -->

<!-- FIN DE LA PAGE HTML -->
</html>






Avant de poser une question, merci de lire la charte du site.
Cordialement, Jordane
Messages postés
110
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 février 2019
9
Si l'image est bien dans le bon répertoire, ça devrait fonctionner. Le code fourni par jordane45 est bien, et propre.
Messages postés
50
Date d'inscription
dimanche 31 janvier 2010
Statut
Membre
Dernière intervention
16 juillet 2015
6
et t'as bien vérifier le dossier ? s'il est bien dans le dossier correspondant ? Si le nom de l'image est exactement le même ? Si l'extension est la bonne ?
Vérifie bien l'orthographe

Dis nous aussi ce qui est noté. Une image avec le symbole cassé ?
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
584
Salut
mis a part ton problème ce n'est pas du html 5 (meme si c'est déclaré comme tel)
les balises orphelines comme img doivent fermer avec ca: />
ensuite en html5 les balises div sont pour la plupart remplacées par des balises sémantiques du genre <header> <article> <footer> <nav> etc ...
ex il vaut mieux mettre une image <img src.. a l'interieur d'une balise <figure>
http://41mag.fr/liste-des-balises-html5/balise-figure-html5
Utilisateur anonyme
Bonjour

Petite remarque : en html5, les balises comme img peuvent se terminer par /> mais ce n'est pas obligatoire.Ce n'est obligatoire que pour les balises étrangères ou en xhtml.
source : https://html.spec.whatwg.org/multipage/syntax.html#start-tags