[Excel] nb de cellules text sans cpter dbl ?

[Fermé]
Signaler
-
Messages postés
17259
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
-
Comment compter un nombre total d'entrees en format textes sans prendre en compte les doublons??
De maniere plus concrete, j'ai une base de donnes d'entreprises, et certaines entreprise ont plusieurs produits; donc certaines entreprises ont plusieurs entrees. J'aimerais donc compter le nombre totales d'entreprises mais je ne sais pas comment faire, une aide ici??

PS: j'ai excel version anglaise car je suis aux usa, merci

1 réponse

Messages postés
17259
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
10 625
Bonsoir Adrien,

Tu peux utiliser la fonction SOMMEPROD de la façon suivante, en supposant que tes données se trouvent en A2:A100 :

=SOMMEPROD(1/NB.SI(A2:A100;A2:A100))

m@rina
et en anglais saurais tu ce que cela donne j'ai essaye avec =SUMPRODUCT(1/NB.IF(A2:A100;A2:A100))

Mais ca marche pas...
Messages postés
17259
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
10 625 > Adrien
C'est une bonne question !! Mais je n'ai pas Excel en anglais sous le coude.

Je pense que tes fonctions sont correctes en anglais, mais le séparateur est par défaut la virgule plutôt que le point virgule. Tu peux le voir dans le panneau de configuration.

m@rina