Sélectionner une plage discontinue dans une fonction

Fermé
Thibodeau19 Messages postés 29 Date d'inscription jeudi 21 février 2013 Statut Membre Dernière intervention 23 janvier 2015 - 21 nov. 2014 à 15:56
via55 Messages postés 14417 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 25 mai 2024 - 21 nov. 2014 à 17:23
Bonjour,

Comment peut-on sélectionner une série de cellules discontinue comme plage d'entrée dans une fonction?

Par exemple, je voudrais entrer dans ma rangée 10 la fonction NB.SI pour compter le nombre de cellules répondant à un certain critère, mais seulement pour les cellules des rangées 2, 4, 6 et 8 de la colonne correspondante.

Je veux ensuite dérouler cette formule pour plusieurs colonnes consécutives.

Si j'avais eu une seule colonne, j'aurais pu nommer le groupe de cellules de ma plage d'entrée, et utiliser ce nom dans ma fonction, mais ça ne peut fonctionner dans ce cas-ci, ou je devrais créer un nom par groupe de cellules pour chaque colonne.

Merci de votre aide!

2 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 399
21 nov. 2014 à 17:08
Bonjour
si réellement vous ne voulez que les lignes 2,4,6,8 (donc les paires de 2 à 8, cette formule pour la colonne A

=SOMMEPROD((MOD(LIGNE(A2:A8);2)=0)*(A2:A8="critère"))

critère entre guillemets seulement si c'est un texte

crdlmnt


0