Formule 2 conditions

[Fermé]
Signaler
Messages postés
11
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
25 octobre 2014
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,

Dans mon tableau excel, certaines cases sont vides, et j'aimerais utiliser un fonction qui compte 1 à chaque fois qu'il voit une ligne avec toutes ses cases vides. Est-ce qu'une telle fonction existe?
Merci d'avance! :)


2 réponses

Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221
Bonjour
comprend pourquoi 2 conditions :-/

Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule

=SOMME(SI(ESTVIDE(B1:B23);1))

à adapter à ton contexte
Messages postés
11
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
25 octobre 2014

En fait j'ai mis ce titre puisque dans mon tableau j'ai 2 colonnes donc 2 conditions pour que la ligne soit vide, mais en écrivant le sujet, je me suis dis que ça pouvait servir à plus de personne si on donnait une formule générale, et j'ai oublié de modifier le titre ^^

Sinon pour ta formule, ça ne marche pas, j'ai Vrai ou Faux comme résultat :/
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Bonjour

et salut Michel, ça faisait longtemps qu'on ne s'était pas croisés,:-))) du moins pour moi

je crois que la question est un peu plus complexe et pour ma part, je n'ai pas d'idée sauf avec une colonne intermédiaire qui compte les lignes vides.
en fait ce que j'ai compris, c'est qu'il faut compter les lignes ou il n'y a rien, par exemple de A1 à C30
Sinon, à mon avis ta formule fonctionne pour une colonne , mais on peut obtenir le résultat sans matricielle avec:
=NB.SI(B1:B23;"")
dans les deux cas la formule compte les cellules vides, pas les lignes.

Mais je peux me tromper, ce ne serait pas la première fois.

crdlmnt


Errare humanum est, perseverare diabolicum
Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221
Bonjour Vaucluse;

ca va ? ;o)

Non, tu as raison! en ce moment, j'essaie de m' habituer avec Win 7 et mon nouveau Pc en 64 bits avec tout un tas d'applications qui sont refusées et j'avoue avoir le cerveau embrumé !

Bon WE espérons ensoleillé pour toi.
Messages postés
11
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
25 octobre 2014

Oui, cette fonction (et la fonction NB.VIDE) ne compte que les cellules et non les lignes, c'est ici mon problème.

Voilà l'image du tableau si ça peut aider, ici c'est les colonnes E et F qui nous intéresse ;)
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
..et elle est où, cette image?

si toutefois votre plage va par exemple de E2 à F100, essayez:

=SOMMEPROD((E2:E100="")*(F2:F100=""))

ou encore Excel à partir de 2007 seulement

=NB.SI.ENS(E2:E100;"";F2:F100;"")

ça devrait correspondre à ce que vous attendez

crdlmnt

Ps: pour Michel> Vu, alors amuses toi bien!