Problème carte wifi debian wheezy

Résolu/Fermé
tantelynomena Messages postés 5 Date d'inscription vendredi 8 novembre 2013 Statut Membre Dernière intervention 24 octobre 2014 - Modifié par tantelynomena le 22/10/2014 à 15:04
mamiemando Messages postés 33184 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 15 juillet 2024 - 26 oct. 2014 à 20:59
Bonjour,




Bonjour,

Je viens ici après 1 mois de galère avec ma carte wifi sur debian wheezy. Je viens d'installer debian wheezy sur mon pc acer aspire v5-571 series et dèjà au moment de l'installation de debian, problème d'installation de serveur DHCP, J'ai ignorer l'étape et voila, debian est installé mais le problème est que j'ai pas accès à wifi. j'ai télécharger soit disant le firmware pour ma carte wifi broadcom 43228 802.11a/b/g/n mais rien. J'ai essayer tous les manip que j'ai vu sur d'autre post, blog, etc ... mais rien. Si quelqu'un peut m'aidez svp.
A voir également:

8 réponses

mamiemando Messages postés 33184 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 15 juillet 2024 7 761
22 oct. 2014 à 19:05
Peux-tu préciser comment tu as installé ton firmware. En théorie tu es sensé

1) activer les dépôts non-free et installer le bon firmware, conformément à ce qui est écrit ici :
https://wiki.debian.org/fr/wl

2) installer network manager :
- sous KDE :
apt-get install plasma-nm

- sous gnome :
apt-get install network-manager-gnome


3) en général il faut redémarrer (pour s'assurer que le firmware est bien chargé)

4) vérifier que la carte apparaît désormais avec la commande suivante (ou directement dans l'applet network-manager, après avoir relancé ta session graphique) :

/sbin/iwconfig


Bonne chance
tantelynomena Messages postés 5 Date d'inscription vendredi 8 novembre 2013 Statut Membre Dernière intervention 24 octobre 2014
22 oct. 2014 à 19:39
C'est exactement le firmware que j'ai installé. Ce pendant, comme je n'ai pas de connexion sur le system debian, je suis passé sous windows puis téléchargeais le paquet broadcom-sta-dkms et l'enregistrais sur mon disque. Ensuite, dans debian, je l'ai installer via l'installateur de paquet; il est belle et bien installé quand je vérifie dans sysnaptic. J'ai aussi installé dkms_2.2.0.3-12_all.deb de la même façon. Je pense que network-manager-gnome est déjà installé par défaut non, vu que j'ai aussi téléchargé ce fichier et quand j'ai voulu l'installer via l'installateur de paquet ça affichais que ce paquet est déjà installé.
mamiemando Messages postés 33184 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 15 juillet 2024 7 761
Modifié par mamiemando le 22/10/2014 à 19:45
Pour vérifier quels paquets sont installés tu peux utiliser
dpkg -l
:

dpkg -l
dpkg -l | grep network-manager


1) Que donnent les commandes suivantes ?


/sbin/iwconfig
lsmod


2) Arrives-tu à scanner les réseaux alentours (
/sbin/iwlist scan
) ?

Bonne chance
tantelynomena Messages postés 5 Date d'inscription vendredi 8 novembre 2013 Statut Membre Dernière intervention 24 octobre 2014
Modifié par tantelynomena le 22/10/2014 à 21:05
Voilà les resultats

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
tantelynomena Messages postés 5 Date d'inscription vendredi 8 novembre 2013 Statut Membre Dernière intervention 24 octobre 2014
22 oct. 2014 à 21:17
voilà le fichier NetworkManager.conf
mamiemando Messages postés 33184 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 15 juillet 2024 7 761
24 oct. 2014 à 15:43
Attention ce sont deux commandes distinctes :

/sbin/iwconfig


... et :

lsmod


Il me faudrait le résultat de la seconde (
lsmod
). Tu n'es pas obligé(e) de prendre une photo. Tu peux directement faire un copier coller c'est plus simple. À ce stade la carte ne semble pas installée correctement vu le résultat d'iwconfig, sans doute parce que le firmware n'est pas installé ou le module wl n'est pas chargé (
modprobe wl
).

Essaye (en root) :

modprobe wl


Assure-toi qu'il est chargé (il devrait alors apparaître avec cette commande) :

lsmod | grep wl


Si c'est le cas, tente de scanner les réseaux alentours :

/sbin/iwlist scan


Si tu ne vois pas de réseau wifi, c'est sans doute que ton firmware est mal installé.

Bonne chance
tantelynomena Messages postés 5 Date d'inscription vendredi 8 novembre 2013 Statut Membre Dernière intervention 24 octobre 2014
24 oct. 2014 à 16:04
Slt

Maintenant ça marche mais c'est très bizarre. J'ai désinstaller le broadcom-sta-dkms et j'ai installer ceci : firmware-brcm80211. Je savais que c'est pas le bon firmware mais je l'ai installer quand même, Je comprend rien vu que le firmware-brcm80211 (0.36+wheezy.1) n'est pas en aucun cas fait pour les chip broadcom BCM43228 802.11a/b/g/n. Quand même dans synaptic ça indique que c'est obsolète, je sais pas peut-être que ça venais du fait que je l'ai installé manuellement (offline).

En tout cas merci.

Tout ça n'est pas normal mais Je vais quand même mettre le post résolu.
mamiemando Messages postés 33184 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 15 juillet 2024 7 761
26 oct. 2014 à 20:59
Bizarre effectivement, normalement ce firmware n'est pas sensé correspondre à ta carte et la doc (et apt) stipule bien que c'est le pilote que tu avais installé (broadcom-sta) que tu es sensé installé. Mais ton retour est néanmoins intéressant, ça laisse penser que ça peut valoir le coup de tenter un autre driver broadcom plutôt que s'acharner avec un driver qui ne semble visiblement pas marcher. Je me souviens avoir rencontré le problème : une carte broadcom (une BCM4313) et rien à faire avec le module wl, ça ne marchait pas.

Pour synaptic je ne sais pas à quoi correspond le statut obsolète, mais ça aussi c'est bizarre qu'il est disponible dans debian jessie qui est plus récente que wheezy. Peut-être que ton firmware provient d'un dépôt (non-free) que tu as désactivé dans l'intevalle.

Pour basculer ton sujet en résolu (je m'en occupe) :
https://www.commentcamarche.net/infos/25917-marquer-un-fil-de-discussion-comme-etant-resolu/

Bonne continuation