.htaccess syntaxe

Résolu
Bonjour,

J'ai écrit un mini-site dans les nuages (1&1), nuage sous apache muni de .htaccess

J'ai essayé plusieurs choses et ou bien il n'y a aucune demande de mot de passe ou bien le nuage me renvoie une erreur 500 (j'ai oublié le libellé exact mais je crois erreur système)

Comme je ne connais pas .htaccess (je me suis servi d'un tuto sur comment ça marche) je voudrais faire vérifier la syntaxe avant de contacter le "maître des nuages"

Dans les nuages j'ai une racine (virtuelle?) un directory Lab, et à l'intérieur de Lab un directory site
J'ai mis .htpasswd (non crypté) dans Lab et .htaccess dans site

.htaccess
AuthUserFile /Lab/
AuthGroupFile /dev/null
AuthName "Accès réservé aux associés"
Authtype Basic

<Limit GET > Require valid-user
</Limit>

.htpasswd
pierreyves : toto

Merci d'avance

5 réponses

  1. Contributeur
    Salut,

    .htpasswd
    pierreyves : toto

    Il ne faut pas d'espaces autour du caractère deux points ( : ) ;-(

    pierreyves:toto
    1
    1. Contributeur
      Et il faut le chemin absolu complet vers le fichier .htpasswd :

      .htaccess
      AuthUserFile /Lab/.htpasswd
      0
  2. Merci; je vais essayer
    J'ai aussi trouvé une majuscule manquante dans AuthType
    0
    1. Même message d'erreur
      Le message exact est:
      Error 500 - internal server error

      un problème inattendu est survenu
      veuillez réessayer ultérieurement
      0
    2. J'ai corrigé le chemin

      AuthUserFile /Lab/.htpasswd
      AuthGroupFile /dev/null
      AuthName "Accès réservé aux associés"
      AuthType Basic

      <Limit GET > Require valid-user
      </Limit>

      et j'ai supprimé les espaces autour des deux points.

      J'ai toujours le même message.

      Est-ce que j'ai le droit de mettre la table des mots de passe à un niveau supérieur au site?
      0
      1. Contributeur
        Je n'en sais trop rien, je ne suis pas spécialiste en matière de serveur Apache et de ses méandres ;-(

        Regarde les liens que je t'ai filés. As-tu contacté le SAV de 1&1 ?
        0
    3. Moi non plus. je suis un pauvre utilisateur lambda.

      Je n'ai pas encore contacté le SAV pour ne pas passer pour une bille. Je vais donc le faire maintenant (ou demain)
      Pour le lien sur l'erreur 500 je te remercie. Il n'y a presque aucun trafic sur mes pages. En revanche je ne sais pas combien de mémoire j'utilise. Il faut que je vérifie que je n'ai pas laissé de trop gros fichiers mais je ne pense pas.
      Pour ce qui est de mettre des # je n'ai mis qu'un seul .htaccess

      Merci de ton aide
      0