Associer une lettre à un chiffre [Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 20 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014
-
Messages postés
13020
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 juin 2021
-
bonsoir,

Après moult recherches j'ai décidé de demander de l'aide...

J'aimerai associer un lettre à un chiffre par exemple lorsque je tape 1 dans une colonne il me marque A dans la colonne à côté .

merci de votre aide

4 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonjour
tout dépend du nombre de code que vous voulez transformez
S'il y en a peu:
=SI(A1=1;"A";SI(A1=2;"B";ect....))
s'il y en a beaucoup , mieux vaut faire un tableau de référence, par exemple
de Y1 à Y10 la liste des lettres
de Z1 à Z10, en ligne les valeurs correspondantes
et en B1:
=SI(A1="";"";RECHERCHEV(A1;$Y$1:$Z$10;2;0))

crdlmnt

Messages postés
2
Date d'inscription
jeudi 20 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014

merci ^^
Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 juin 2021
4 637
Bonsoir,

il y a également la fonction choisir, il suffit de saisir en A1 une valeur entre 1 et 26

=CHOISIR(A1;"A";"B";"C";"D";"E";"F";"G";"H";"I";"J";"K";"L";"M";"N";"O";"P";"Q";"R";"S";"T";"U";"V";"W";"X";"Y";"Z")

et à partir d'Excel 2007 avec cette gestion d'erreur

=SIERREUR(CHOISIR(A1;"A";"B";"C";"D";"E";"F";"G";"H";"I";"J";"K";"L";"M";"N";"O";"P";"Q";"R";"S";"T";"U";"V";"W";"X";"Y";"Z");"")

pour les versions antérieures formule plus longue avec si(esterreur

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
13020
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 juin 2021
2 200
Bonsoir à tous

On peut faire plus court comme formule

le nombre en A1, en B1 : = CAR(64+A1)

Cdlmnt