Calcul cellules selon mois

Fermé
Signaler
-
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
-
Bonjour,

Je souhaiterai faire un calcul dans mon tableau. j'ai une colonne client , une colonne montant totale de la commande et une colonne délais. J'aimerai faire la somme de tous les totaux mais qui sont pour le mois de mars ! (ou avril ou mais ou juin...)

Une solution ?

Merci d'avance !

1 réponse

Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 855
Bonjour,

un exemple les dates en colonne B et les valeurs en D

=SOMMEPROD((MOIS($B$2:$B$20)=3)*($D$2:$D$20))
ou si le mois est saisi en toute lettre
=SOMMEPROD((MOIS($B$2:$B$20)="mars")*($D$2:$D$20))
ou le mois est saisi dans une cellule exemple en G7
=SOMMEPROD((MOIS($B$2:$B$20)=MOIS(G7))*($D$2:$D$20))
et en nommant les plage exemple B2:B20 nommée col_b et D2:D20 col_d
=SOMMEPROD((MOIS(col_b)=MOIS(G7))*(col_d))