Connection No-ip ssh mais pas web

[Résolu/Fermé]
Signaler
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014
-
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014
-
Bonjour à tous, je vous expose mon problème...

Contexte :

J'ai monté un raspberry avec un NAS sur lequel j'ai installé SSH, subsonic, no-ip et un semblant de page web.

Le problème :

En réseau local la connexion au SSH fonctionne c'est le cas aussi pour la page web, toutes les données du NAS et l'accès à subsonic.

En connexion externe via l'ip publique du raspberry j'arrive à me connecter à tout sans problème.
En connexion externe via no-ip cette fois ci je peux me connecter au ssh (ça devrait marcher pour le reste normalement...) mais pas à la page web ni à subsonic...

Si quelqu'un à ne serait-ce qu'un semblant d'idées :D

Merci de m'accorder votre temps :)

12 réponses

Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
Il faut que tu rediriges ton port 80 correspondant à l'IP locale de ton NAS, dans la page NAT de ton modem... C'est lui qui empeche le passage de ton web avec le monde extérieur...

Tu peux tester ton port avec ça https://canyouseeme.org

et aussi: https://www.whtop.com/tools.website

Tu n'y verras pas ta page Web, mais il te diras l'état de ta connexion, ce qui passe et ce qui ne passe pas
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

J'ai omis de préciser que les port 22, 80 et 443 sont redirigés vers le raspberry :/
Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
OK, tu ne l'avais pas dis.... Mais il n'est pas possible de donner le même port à deux équipements... Donc actuellement, No-ip arrive sur ton raspberry...

Si tu veux qu'on accède depuis le Web à ton NAS, il faut qu'il ai le port 80 c'est le standard ... Et pour cela tu changes par 8080 celui de ton raspburry... Puisque son accès est interne... Par contre son accès sera.... ip-raspburry:8080 il faudra taper le N° de port derrière son N° d'IP... je crois que tu n'as pas le choix.
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Oui désolé :/
en fait ce que j'appelle NAS est un disque dur relié au raspberry, le NAS est le raspberry en quelques sorte !
Et je ne suis pas sûr de comprendre, quand je tape mon adresse publique pour ma page web je tape xxx.xx.xx.xxx et la j'arrive sur ma page nginx, pour subsonic je tape xxx.xx.xx.xxx:4040 et j'arrive sur ma page subsonic je ne pense donc pas que ça soit un problème de port si ?
Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
Ta page web...?? elle est sur ton disque dur (qui n'est pas un NAS) est-ce que tu y accède bien sur ton réseau Local..? en tapant son N° d'IP dans l'URL de ton navigateur..?

Parce que ton NGINX et subsonic, je ne sais pas trop ce que c'est et je ne vois pas l'intéret d'accéder à un site de music...

Est-ce que ton site web est bien conforme à la mise en page, format etc.. selon les règles..?
Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
Je me suis documenté un peu..., J'en conclu que l'accès est normal vers Subsonic; et c'est NGINX qui fait serveur qui doit répondre au port 80 au lieu de ton site WEB...

Documentation Nginx: https://rasyid.net/2008/08/06/101-nginx-tutorial-and-articles/

Alors, il faudrait que NGINX pointe directement sur le Fichier "Index" de ta page Web... C'est Lui qui fait le rôle de server Http, donc c'est normal que l'accès externe arrive là... C'est ensuite le lien vers ton site qui ne doit pas marcher correctement

J'ai lu aussi:
Corriger le problème de l'adresse IP des clients

Un petit problème peut se produire lorsque l'on utilise un reverse-proxy comme dans notre configuration : l'IP des clients affichée par certains scripts PHP sera l'IP du proxy (127.0.0.1 si les deux processus sont sur la même machine). C'est le cas par exemple pour l'IP des commentaires dans WordPress.
Pour corriger ce problème, une solution relativement simple existe : l'installation du module rpaf.

Sous debian, l'installation de mod_rpaf s'effectue le plus simplement du monde :

apt-get install libapache2-mod-rpaf
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Ah oui intéressent tout ça ! Merci beaucoup je vais tester ça !

Mais ça voudrait dire que subsonic et nginx sont en conflit c'est ça ? donc si j'essaie de couper l'un temporairement je devrait pouvoir accéder à l'autre via mon adresse noip ?
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

J'ai réglé le problème, c'était bien un conflit de port, non seulement le port web et subsonic interférais et j'avais de toute façon oublié de faire une ouverture de port sur le raspberry en plus de la livebox....

Merci beaucoup pour ton investissement et ta lumière :) !
Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
et bien, tant mieux pour toi, je suis ravi d'avoir pu deviner la rupture du lien et pouvoir t'éclaircir la vue de synthèse de ton sysytem...!

Dis-moi si j'ai compris, ton "Subsonic", il ne fait média server que pour la music et le son...? et pas pour les photo et la vidéo...?

Car j'ai une action en cours actuelement, basée sur XBMC (archlinux) pour faire un serveur média complet: Music, Photo, TV et vidéo et lecteur DVD ... Donc je m'intéresse au sujet...
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Que de politesses :D

Le but de Subsonic en fait c'est de streamer sa musique, j'y accède ainsi n'importe ou (pratique pour les soirées !) à l'image de grooveshark ou deezer sauf que la j'héberge le site et la musique... En effet c'est prévu pour streamer musique, radio internet et podcast mais je me demandais aussi pour la vidéo... je vais me renseigner je te redis !
Et si je me souviens bien XBMC c'est pour un serveur média chez soit seulement en local non ?

Tu comptes faire tourner XBMC sur ton raspy relié à un écran ?
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Encodage FLV pour la vidéo
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Je test un stream vidéo je vois ce que ça donne ;)
mais je doute que la bande passante suffise à streamer un film depuis chez moi...
Messages postés
21635
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 octobre 2021
5 629
En gros c'est ça...Oui, c'est uniquement Local c'est un "Home Média Center"

Mais je compte le placer dans un "petit PC" sous Linux, il fait récepteur TNT avec une carte Hauppauge et Magnétoscope (disque dur), lecteur DVD avec le DVD du PC et DLNA pour Music, photo, Vidéo (sur un NAS) ..Internet, Télécommande.

Cet appareil est relié au réseau local et sort sur un écran TV sur HDMI

Voila la structure... et ça accepte plusieurs formats Vidéo, et autres. sortie son 5.1
Messages postés
22
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 janvier 2014

Et bien dans ce cas subsonic t'es pas vraiment utile c'est surtout pour stremer de la musique et que ça soit accessible depuis internet (extérieur). Tu peux regarder "Plex" c'est similaire à XBMC mais c'est nouveau c'est peut etre plus fluide je sais pas :)