Ouverture pièce jointe dans Thunderbird-2.0 [Fermé]

Signaler
Messages postés
3
Date d'inscription
dimanche 6 mai 2007
Statut
Membre
Dernière intervention
6 mai 2007
-
 roger -
Bonjour,

Sous Gentoo et TB-2.0

Si dans un courrier je reçois une pièce jointe, par exemple en .pps,
et que je veux l'ouvrir, j'ai ce message: "fichier.pps" n'a pas pu être
ouvert car l'application auxiliaire associée n'existe pas. Changez cette association dans vos préférences.

Dans Édition-Préférences-Pièces jointes-Voir et modifier les actions
il n'est pas possible de faire une association pour ouvrir le .pps
Par contre je peux l'ouvrir, si je l'ai enregistré, avec OOo Impress.

Comment faire cette association avec l'application auxiliaire afin que
la pièce jointe s'ouvre avec un clic droit dessus dans TB?

Merci pour votre aide
DocRog

13 réponses

Salut essaye de aller dans outils/options/pièces jointes/voir et modifier l'action, et cherche ton tipe de fichier ''pps'' et tu clique et tu vas sur modifier l'action ensuite il faut choisir '' LES OUVRIR AVEC CETTE APPLICATION'' ET TU CHERCHE TON APPLICATION ''POWERPOINT'' DANS C:\Program Files\Microsoft Office\OFFICE11/powerpoint.

Dis moi si tu as réussi.
Bonne chance.
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Super cela marche
Bonjour à tous,

Votre problème vient certainement du fait que vous gardez le même répertoire ".thunderbird" au fur et à mesure des versions du courrielleur. Cela est normal quand on veut garder ses archives mèl. Cependant la syntaxe du fichier de configuration des associations a évolué avec les versions. Cela a pour conséquence de verrouiller certaines entrées.

Mon conseil : supprimez le fichier /home/nom-de-login/.thundirbird/nom-profil-thundirbird/mimeTypes.rdf à chaque changement de version majeure de thundirbird.

Rexy sous Mandriva Linux.
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016
1 749
Sinon tu peux aussi aller dans Edition. Préférences. Pièces-jointes, et modifier mes actions. Et tu testes.
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 849
Je cite : "Dans Édition-Préférences-Pièces jointes-Voir et modifier les actions
il n'est pas possible de faire une association pour ouvrir le .pps
"

;-))
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016
1 749
Bien vu lol. C'est un problème déjà rencontré sur les forums de TB, et je n'ai pas vu de solutions vraiment. Tu pourrais peut-être essayer de poser la question sur le forum de TB. Sinon, bonne chance.
Messages postés
3
Date d'inscription
dimanche 6 mai 2007
Statut
Membre
Dernière intervention
6 mai 2007
1
Je ne vois pas où tu trouves l'association de fichiers dans OOo (ni dans TB d'ailleurs)

Merci pour toutes vos réponses.
J'attends la bonne!
DocRog

Bonjour

J'ai eu le même problème tout à coup avec les xls, quand je suis passé à la version 2.0 de Thunderbird.

Tu peux essayer la manipulation suivante :

- va dans ton répertoire de profil (genre C:\documents and Settings\[Nom du profil Windows]\Application Data\Thunderbird\Profiles\[Nom du profil Thunderbird]

- fais une copie de sauvegarde du fichier mimeTypes.rdf

- ouvre le fichier mimeTypes.rdf avec un éditeur de texte, au pire le bloc-note de Windows - que je te conseille de remplacer par Notepad ++ ou Notepad2 :-)

- cherche les références à Powerpoint et aux fichiers ppt (rechercher : Powerpoint et rechercher : ppt) et supprime les passages correspondants (depuis "<RDF:Description" jusque "</RDF:Description>
") :

Par exemple, dans mon fichier, j'ai supprimé les références suivantes :

<RDF:Description RDF:about="urn:mimetype:handler:application/vnd.ms-excel"
NC:saveToDisk="false"
NC:alwaysAsk="false"
NC:useSystemDefault="true">
<NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/vnd.ms-excel"/>
</RDF:Description>

<RDF:Description RDF:about="urn:mimetype:application/vnd.ms-excel"
NC:value="application/vnd.ms-excel"
NC:editable="true"
NC:fileExtensions="xls"
NC:description="Feuille de calcul Microsoft Excel">
<NC:handlerProp RDF:resource="urn:mimetype:handler:application/vnd.ms-excel"/>
</RDF:Description>

- Ferme et relance Thunderbird

- Normalement, quand tu as une pièce jointe ppt, il te demande maintenant quel programme utiliser. Il te reste qu'à lui indiquer, en demandant qu'il fasse toujours ainsi.

Si ça ne marche pas, tu peux toujours supprimer le fichier mimeTypes.rdf modifié, et remettre la copie de sauvegarde à la place...

Oups, j'avais pas vu que tu étais sous Linux.
Les chemins indiqués ne sont donc évidemment pas bon, mais la manipulation devrait marcher quand même, une fois que tu auras localisé le fichier mimeTypes.rdf
bon , j'ai eu le pb avec firefox et je donne ma soluce à tout hasard. Aller dans outils - options - contenu- type de ficheirs + gérer et supprimer la ligne qui pose pb. En principe, tout doit fonctionner de nouveau normaement.
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016
1 749
Salut
Dans la fenêtre qui s'ouvre sous TB pour tenter d'ouvrir le .ps, tu écris en bas (nom du programme ou un truc comme ça) openoffice. Et tu coches toujours sélectionner cette action. Si tu peux pas écrire, tu choisis ouvrir avec autres, et là tu sélectionnes TB.
Voilà j'espère que cela t'aidera
Messages postés
3
Date d'inscription
dimanche 6 mai 2007
Statut
Membre
Dernière intervention
6 mai 2007
1
Merci pour la rapide réponse, mais ça ne marche pas!

Le clic droit sur la pièce jointe en .pps puis "ouvrir"amène aussitôt la réponse citée dans le post précédent.
Je ne peux pas inscrire quelque chose au niveau de la pièce jointe.

Si je l'ouvre après L'AVOIR ENREGISTRÉE, la fenêtre qui apparait a bien "Utiliser cette action par défaut pour ce type de fichiers" cochée, et ouvre le fichier .pps
Comment donc ouvrir DIRECTEMENT dans TB la pièce jointe pps située en bas du courrier?
Merci DocRog
Messages postés
14710
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
5 avril 2021
2 291
bonjour,
chez moi ça fonctione au poil , et je n'ai rien regle dans thundirbird par contre les fichier pps sont associer avec Ooo dans association de fichier .
a+
Messages postés
14710
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
5 avril 2021
2 291
bonsoir,
quelle distribution , sous kde ou gnome ou autre?
a+
Bonjour,
je suis sous ubuntu et j'ai le meme probleme. auriez vous une reponse ?
Merci
Merci pour cette réponse, je vais tester dès maintenant.
Résolu par Captain Stan & Rexy.

Merci beaucoup ! Je commençais à en avoir assez de devoir enregistrer toutes les PJ avant ouverture. Comment ai-je pu ne pas penser à chercher un fichier de ce type .... Pov' type ! ;o)

Merci
Bonjour,

Je me permets d'enlever le statut [Résolu] de ce message car je rencontre le même type de problème avec XnView pour ouvrir des fichiers PSP et Thunderbird ne permet pas de sélectionner "Toujours effectuer cette action pour ce type de fichier"

Quelqu'un aurait-il une solution pour cette application ?

Merci par avance pour vos réponses et bonne fin de journée.
Nicolas
La méthode de captain stan marche impec pour moi.
Merci