Je cherche à compter deux chiffres dans une base de données

[Fermé]
Signaler
Messages postés
1
Date d'inscription
lundi 6 janvier 2014
Statut
Membre
Dernière intervention
6 janvier 2014
-
Messages postés
54837
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
-
en colonne a, j'ai la journée
de la colonne b à k, j'ai différents chiffres de 1 à 30.
les chiffres en colonnes b et k n'ont pas de valeurs en tant que tel, le chiffre étant unique et je ne fais pas de calcul avec ceux-ci.

Ce que je voudrais, c'est d'avoir le nombre de fois où le 1 ET le 19 disons sont dans la plage B1:k600.

J'ai cherché avec la formule si, si.nb. si.nb.ens, sommeprod et rien de tout cela ne fonctionne, j'ai un 0 comme réponse

Merci de m'aider

je fonctionne en excel 2007

4 réponses

Messages postés
54837
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
16 735
Où sont ton fichier et tes formules ?

Pourquoi as-tu effacé le "Bonjour" qui était déjà écrit en début de message (pour être certains que tu ne l'oublierais pas) ?
https://www.commentcamarche.net/contents/129-charte-d-utilisation-de-commentcamarche-net-respect-d-autrui

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonjour
Vous avez essayé NB.SI dites vous?
c'est assez curieux car si on reprend votre question, la formule ci dessous devrait fonctionner
=NB.SI(B1:K600;1)+NB.SI(B1:K600;19)
sauf si vos cellules sont en format texte auquel cas il faut placer le 1 et le 19 entre guillemets.
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
54837
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
16 735
Non, Vaucluse : il n'a pas essayé NB.SI mais il a inventé une nouvelle fonction si.nb
Bonjour M. Vaucluse et M. Pentier et merci encore de vous soucier de mon problème.

Je me suis effectivement mal exprimée lors de la formulation de ma question

La formule que vous avez émise donne l'addition des deux critères soit le 1 et le 19, mais, je ne trouve pas la solution pour qu'excel ne confine le résultat lorsque sur la même ligne de la colonne B à K le 1 et le 19 sont présents.

Est-ce qu'à ce moment là, je drois prendre la formule nb.si.ens. Mes cellules sont en mode standard

J'ai tenté la formule suivante =nb.si.ens(b1:k600;1;b1:k600;19), mais Excel me renvoie 0 comme réponse alors que ce nombre doit être supérieur à zéro

Merci de votre temps
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Je n'avais pas capté le fait qu'il fallait compter les lignes quand 1 et 19 sont sur la même ligne.
Pour ma part et pour l'instant, je ne sais faire ça qu'avec une colonne intermédiaire, par exemple en L de 1 à 600, la formule:
=SI(ET(NB.SI(B1:K1;1);NB.SI(B1:K1;19));1;"")
cette colonne peut bien sur se placer n'importe où, se masquer, sur une autre feuille ect..
et ensuite hors champ:
=SOMME(L1:L600)

Mais vous trouverez sans doute quelqu'un pour vous donner la bonne formule
Bonne chance

crdlmnt
Messages postés
54837
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
16 735
Garyuser, je t'invite à relire ta question initiale.
Ce n'est pas du tout ce que tu nous racontes maintenant ...
Alors pour éviter toute autre erreur de compréhension, envoie ton fichier (Tu vas dans https://www.cjoint.com/ pour créer le lien, que tu reviens coller ici).