Le fichier .htaccess

Fermé
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
- Modifié par Ennemine le 6/11/2013 à 09:32
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
- 16 nov. 2013 à 15:57
Bonjour tout le monde

Je suis nouveau sur le forum, et je suis un débutant aussi, donc aidez-moi.

Je suis sous Windows7 et j'utilise WampServer2.1e-x32 et mozilla25. aprés des longues recherches sur le net j'ai trouvé que je dois faire mon .htaccess comme suit :

voici lecontenuu de ce fichier chez moi :


1 #Fichier .htaccess : /dossier_no3/
2 Options +FollowSymlinks
3
4 RewriteEngine on
5 RewriteOptions Inherit
6
7 RewriteRule ^page1.php$ saisit.php[L]
8 RewriteRule ^page2.php$ saisit1.php[L]
9 RewriteRule ^page3.php$ affich.php[L]
10 RewriteRule ^page4.php$ affich.php[L]
11 RewriteRule ^page5.php$ livreor.php[L]
12 RewriteRule ^page6.php$ contact.php[L]
13 RewriteRule ^page7.php$ contacta.php[L]
14 RewriteRule ^page8.php$ info.php[L]
15 RewriteRule ^page9.php$ infoa.php[L]
16 RewriteRule ^page10.php$ sitsa.php[L]
17 RewriteRule ^page11.php$ nous.php[L]
18 RewriteRule ^page12.php$ nousa.php[L]

Et quand je lance mon site je trouve ce message :



Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Aidez-moi, c'est urgent .

4 réponses

tryan44
Messages postés
1288
Date d'inscription
mardi 24 janvier 2012
Statut
Membre
Dernière intervention
26 octobre 2014
232
6 nov. 2013 à 10:09
Salut,

A tester ...

Supprimez la ligne :
RewriteOptions Inherit
et remplacer par :
RewriteBase / 
0
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
2
7 nov. 2013 à 12:29
Rien a changé avec

Supprimez la ligne :

RewriteOptions Inheritet

remplacer par :

RewriteBase /
0
bg62
Messages postés
23340
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
12 août 2022
2 323
6 nov. 2013 à 11:46
alors : bienvenue sur CCM ... :)
mais :
Je suis sous Windows7 et j'utilise WampServer2.1e-x32 et mozilla25. aprés des longues recherches sur le net j'ai trouvé que je dois faire mon .htaccess comme suit :

voici lecontenuu de ce fichier chez moi
- rien à voir avec windows
- 'chez moi' = où ???
- 'longues recherches' = sûr qu'elles sont bonnes ;)
@+
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
7 nov. 2013 à 13:52
essaie ca

Options +FollowSymlinks
RewriteEngine on
RewriteBase /

RewriteRule ^page1\.php$ saisit.php [L]


le [L] avec un espace avant

0
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
2
8 nov. 2013 à 18:56
Cher animostab votre solution ne marche pas pour moi??
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
Modifié par animostab le 8/11/2013 à 22:58
la solution donnée précedemment marche normalement supprime les lignes vides

Options +FollowSymlinks
RewriteEngine on
RewriteRule ^page1\.php$ saisit.php [L]

sinon
petites questions

les pages a rewritées sont elles dans un répertoire ? si oui quelle est l'arborescence?

le .htaccess est il dans un répertoire (lequel) ou à la racine du site

y a t il des fichiers ayant déjà le nom saisit.php saisit1.php ou autre nom rewrité ?

Tous les fichiers a rewriter existent ils ?

dans la configuration du serveur le mod rewrite est il activé ?
il ne faut pas un # devant ces lignes

dans httpd.conf a la ligne :
LoadModule rewrite_module modules/mod_rewrite.so

dans php.ini
url_rewriter.tags
0
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
2
9 nov. 2013 à 23:11
Les pages a rewritées sont tous dans le même répertoire avec le fichier .htaccess. sont donc à la racine du site. il n'y a que deux fichiers portent le nom saisit.php et saisit1.php et tous les fichiers a rewriter existent . et dans la configuration du serveur le mod rewrite est activé.
pas de # devant : LoadModule rewrite_module modules/mod_rewrite.so .
dans httpd.conf .

Mais dans php.ini il n' ya que (;) dans tous le fichier et avant url_rewriter.tags bien sur ??
0
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
2
Modifié par Ennemine le 9/11/2013 à 23:46
Es que ça peut être un problème de compatibilité?
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
Modifié par animostab le 10/11/2013 à 14:20
le problème pourrait venir que tu as des fichiers saisit.php et saisit1.php
si tu rewrite et que des fichiers existe déjà sous le nom a rewriter ca pourrait peu être générer une erreur
pour ces fichier il faudrait faire une redirection 301 ou les supprimer

le point virgule c'est normal dans php.ini (sans accolade)
0
Ennemine
Messages postés
67
Date d'inscription
mercredi 6 novembre 2013
Statut
Membre
Dernière intervention
11 juillet 2016
2
Modifié par Ennemine le 10/11/2013 à 14:23
Bon, aidez moi pour le moment a s'adapter ce code avec mon site et je laisse le .htaccess après.

Je veux afficher dans l'URL localhost/ejbardhalla/page1.html au lieu de localhost/ejbardhalla/affich.php

 <?php




$nouveau_texte = eregi_replace(

"(http|https|ftp)://([[:alnum:]/\n+-=%&:_.~?]+[#[:alnum:]+]*)",

"<a href=\"\\1://\\2\" target=\"_blank\">\\1://\\2</a>",$txt_orig);



?>
0