Où dois-je monter ma partition Windows ? [Résolu/Fermé]

Signaler
Messages postés
257
Date d'inscription
jeudi 16 juin 2011
Statut
Membre
Dernière intervention
18 septembre 2014
-
Messages postés
2677
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
30 janvier 2015
-
Bonjour à tous !
suite à une fausse manip, j'ai monté ma partition windows dans /media/mondossier/ sauf que depuis cette fausse manip, Grub refuse de booter sur windows.
J'ai démonté la partition, mais je sais pas où la remonter pour que Grub la retrouve !

(Bon vous me direz, c'est pas plus mal, je suis en full Linux mais bon...)

Merci à vous !

3 réponses

Bonjour,
Le point de montage de la partition windows n'a absolument aucun rapport avec ton problème de démarrage.
Lorsque tu montes la partition Windows (et tu peux la monter où bon te semble) c'est uniquement pour pouvoir accéder à son contenu sous linux.
Grub n'utilise pas ce point de montage pour lancer Windows.

Par contre, lorsque tu as accédé à cette partition, tu n'aurais pas effacé/modifié ou déplacé un fichier système par hasard ? Ça me semble le plus plausible.
A tout hasard, tu peux tenter de lancer la commande update-grub dans le terminal administrateur mais si tu as touché aux fichiers système de Windows je doute vraiment que ça fonctionne.
Messages postés
2677
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
30 janvier 2015
570
Je suppose qu'au démarrage de ton PC , le grub affiche au menu choix 1 linux, choix 2 Windows, ou qq chose comme ça. Rassure moi, le menu de démarrage tourne toujours.Auquel cas essaye de réparer windows avec le CD officiel.

Bjr,

Tente la commande de jns55 ou carrément

sudo apt-get install --reinstall grub-pc grub-common

De quel Windows s'agit-il ? Possèdes-tu le DVD d'installation ? Le disque dur est-il au format mbr (autrement dit, as-tu un bios traditionnel) ?

As-tu vérifié par un sudo os-prober que ton Ws est toujours identifié ?
Donne-nous aussi le résultat d'un sudo fdisk -l pour qu'on voie où en sont les partitions.
Messages postés
257
Date d'inscription
jeudi 16 juin 2011
Statut
Membre
Dernière intervention
18 septembre 2014
10
Pour les autres questions, il s'agit de W7, j'ai le dvd, et le disque dur est bien en mode MBR

fdisk :

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 1758019347 878906250 7 HPFS/NTFS/exFAT
/dev/sda3 1758019582 1953523711 97752065 5 Extended
Partition 3 does not start on physical sector boundary.
/dev/sda5 1943568384 1953523711 4977664 82 Linux swap / Solaris
/dev/sda6 1758019584 1935316991 88648704 83 Linux
/dev/sda7 1935319040 1943560191 4120576 82 Linux swap / Solaris

La plus grande partition est Windows
Re,

Comme tu vois, il y a un problème ici , Partition 3 does not start on physical sector boundary. . De plus, il y a des bizarreries dans l'ordre des partitions 4, 5 et 6 Et tu as 2 swap. Selon moi, tu as peut-être un problème avec la table de partitions. Regarde avec gparted si le problème semble se confirmer. Et ton Linux démarre ?

C'est quel Linux ? Et quel Windows ?

Moi, je tenterais une réparation du mbr avec la console windows correspondant à ta version... ou avec boot-repair, et si ça passe, je réinstallerais mon Linux proprement après suppression des partitions qui semblent buguer.
Messages postés
257
Date d'inscription
jeudi 16 juin 2011
Statut
Membre
Dernière intervention
18 septembre 2014
10
Effectivement c'est le bazar dans les partitions
Je crois que je vais laisser mes données sur un DD externe et tout formater pour repartir sur de bonnes bases ^^!

Merci !
Utilisateur anonyme
Un peu radical, mais c'est toi qui vois. Bye
Messages postés
2677
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
30 janvier 2015
570
essaye l'option "réparer" avant de formater.