Affichage des numeros de semaine entre deux dates [Fermé]

Signaler
Messages postés
5
Date d'inscription
jeudi 12 septembre 2013
Statut
Membre
Dernière intervention
27 septembre 2013
-
Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
-
Bonjour à tous,
Est-ce que quelqu'un aurait la formule magique ?
date arrivéee date jour N°semaine
01/09/2013 12/09/2013 37
16/09/2013 12/09/2013 38
23/09/2013 12/09/2013 39
30/09/2013 12/09/2013 40


si date arrivée est superieure à la date du jour alors affiche le numero de semaine de la date arrivée

si date arrivée est inférieure à la date du jour alors affiche le numero de semaine de la date du jour

Merci d'avance
A voir également:

1 réponse

Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
3 169
Bonjour

arrivée colonne A jour colonne B
=(ENT(MOD(ENT((SI(A2<B2;B2;A2)-2)/7)+0,6;52+5/28))+1)

nota;la fonction Excel "N°semaine" n'est pas valable en europe (Excel<2010)

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
3 169
extrait du site de Laurent Longre, GranD Manitou Excel reconnu par Microsoft

..."La formule renvoie le numéro de semaine conforme à la norme ISO, utilisée dans les pays européens (la première semaine d'un mois étant définie comme la première semaine comportant au moins quatre jours dans le mois).
ATTENTION, si l'on veut calculer des numéros de semaines ISO, ceux en particulier du calendrier français, il ne faut pas utiliser la fonction NO.SEMAINE proposée par l'Utilitaire d'analyse. Celle-ci renvoie un numéro de semaine calculé d'après la méthode utilisée aux États-Unis, qui n'est pas conforme à la définition ISO utilisée en France. "...
Messages postés
5
Date d'inscription
jeudi 12 septembre 2013
Statut
Membre
Dernière intervention
27 septembre 2013

merci bcp,
j'ai utilisé ça comme formule
=SI(B3>AUJOURDHUI();ENT((B3-SOMME(MOD(DATE(ANNEE(B3-MOD(B3-2;7)+3);1;2);{1E+99;7})*{1;-1})+5)/7);ENT((C3-SOMME(MOD(DATE(ANNEE(C3-MOD(C3-2;7)+3);1;2);{1E+99;7})*{1;-1})+5)/7))
Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
3 169
Alors, pourquoi demandes tu de l'aide ?