Supprimer le dernier caractére d'une cellule pour une colonne [Fermé]

Signaler
-
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
-
Bonjour,

De dois faire une comparaison automatique entre deux colonnes censés contenir les même données.

Mon problème est que ces deux colonnes sont à peut près comme ça :

0
51.26 51.26;
50.26 50.26;

Quand je faire la comparaison de la première ligne on me dit "ok" car Excel comprend qu'elles sont vide. Mais pour la deuxième il me met "PB" car il pense que se ne sont pas les même données.

Tout ça pour un malheureux point virgule.
Je voudrait donc faire une nouvelle colonne contenant les même données que la deuxième mais sans le point virgule. Je m'en servirai ensuite pour ma comparaison. Quelqu'un peut il m'aider ?
A voir également:

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
520
Bonjour,

Le texte à modifier étant en B1, tu places en C1 la formule
=SI(DROITE(B1;1)=";";GAUCHE(B1;NBCAR(B1)-1);B1)
puis copier avec la poignée de recopie.
A+
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 903
Bonjour
au plus simple
sélectionnez la colonne, ou copier la si vous ne voulez pas la détriure
touches ctrl+h
remplacer
entrez en haut remplacer: ;
par en bas : n'entrez rien
remplacer tout
crdlmnt

Errare humanum est, perseverare diabolicum