Somme sur plusieurs feuilles avec condition de date

[Fermé]
Signaler
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013
-
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013
-
j'ai plusieurs feuilles avec une date de paiement ds la cellule B23 et un montant dans la cellule G23
Sur ma feuille récap il y a une date en B2. Je voudrais faire la somme de tout les montant de toute les feuilles qui ont la même date de paiment que ma récap sachant que le nombre de feuilles varie
J'espère avoir été clair et recevoir de l'aide rapidement

7 réponses

Messages postés
1429
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
8 juin 2021
486
Hello,
Je peux te proposer une solution en attendant que d'autre personnes arrivent.

Ma solution va être avec un code un peu exhaustif.
Il te faudra avoir le nom des onglets de toutes tes feuilles.
Ensuite sur l'onglet où tu fais le récap tu devra alors y écrire quelque chose comme :

=SI(B2=B23!NOM_ONGLET_1;G23;0)+SI(B2=B23!NOM_ONGLET_2;G23;0)+SI(B2=B23!NOM_ONGLET_3;G23;0)+SI(B2=B23!NOM_ONGLET_4;G23;0) etc...
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

Mon souci c'est que je ne connais pas à l'avance le nombre de feuilles
Messages postés
1429
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
8 juin 2021
486
Ah ouais mais tu complique la chose là !
Si tu veux prévoir un calcul avec des onglets qui n'existeront peut être pas c'est compliqué !
On peut toujours trouver une solution !
Le nom de tes onglets sont t'il toujours les mêmes ? Ou suivent ils une suite logique ?
Ex : Feuille1, Feuille2, Feuille3...
Ou
Janvier 2013, Février 2013, Mars 2013...
Messages postés
1429
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
8 juin 2021
486
Ce que tu peux faire c'est alors de prévoir un calcul avec celui que je t'ai montré plus haut avec la fonction INDIRECT() qui aura pour but d'avoir un onglet en attente et le jour où tu le créer alors il sera intégré au calcul.

=SI(B2=INDIRECT("NOM_ONGLET_1" & "!B23";G23;0)+SI(B2=INDIRECT("NOM_ONGLET_2" & "!B23";G23;0)+
SI(B2=INDIRECT("NOM_ONGLET_3" & "!B23";G23;0)+
SI(B2=INDIRECT("NOM_ONGLET_4" & "!B23";G23;0)+
SI(B2=INDIRECT("NOM_ONGLET_5" & "!B23";G23;0)
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

je vais essayer parcontre est ce que je dois faire attention a insérer mes nouvelles feuille avant l'onglet 5 (dans ton exemple)
Messages postés
1429
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
8 juin 2021
486
Non je pense pas, il doit regarder dans tout le classeur normalement.
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

merci je reviendrais si un echec de plus !
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

Echec
Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Bonsoir,

Tu peux utiliser la fonction détournée de SOMMEPROD, sur la feuille 1 par exemple dans une cellule tu saisis le critère jour (la date de référence)

sur chaque feuille tu utilises la fonction SOMMEPROD en fonction du critère feuille1

reste plus qu'à faire la somme des feuilles du classeur avec la simple formule style
=SOMME(Feuil2:Feuil8!G2)
G2 si toutes les SOMMEPROD sont en G2
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

j ai pas tout compris que dois je faire avec sommeprod.
J'ai jamais utilisé cette fonction
Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Re,

Alors pour ne pas te perdre par exemple sur la première feuille nommée Feuil1 cellule G2 tu saisis la date de payement

ensuite sur chaque feuille tu as en colonne A tes dates et en colonne B tes montants et en E1 par exemple tu as une formule SOMMEPROD pour la feuille

=SOMMEPROD((A2:A50=Feuil1!G2)*(B2:B50))
ensuite sur la première feuille ou celle de ton choix tu peux utiliser cette formule qui additionnera toutes les valeurs de la cellule E1 qui se trouveront entre la feuille nommée Feuil1 et Feuil8

=SOMME(Feuil1:Feuil8!E1)

Si tu n'y arrives pas je te ferais un petit montage

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

En fait je n'ai pas de feuille où il y a toute les dates et tout les montants.

J'ai plusieurs feuilles qui représente des "factures" . Quand le client paye je mets la date de paiement et la somme payée (dans des cases différentes selon le mode de paiement)
.
Chaque jour je dois faire un arreté de caisse je dois donc additionner toute les somme payé en cheque, en monnaie, etc. si elle ont été payé ce jour

exemple :
facture1 : 100 € en chèque payé le 12/07
facture2 : 50 € en chéque payé le 12/07
facture3 : 20 € en numéraire payé le 12/07
facture4 : 20€ en chèque payé le 16/07
arrétécaisse : le 12/07 j'aurai 100+50=150 dans la case chèque et 20 dans la case numéraire
la facture 4 n'est pas prise en compte puisque pas payé a la bonne date

j'espère que c'est clair et que tu pourras m'aider je désespère !
En tout cas merci !
Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Re,

Oui et bien c'est le même procédé, construit un exemple de fichier avec quelques noms et versements factices et joint ton fichier avec ce lien

https://www.cjoint.com/

il y a également cette formule

=SOMME.SI.ENS(B2:B30;A2:A30;Feuil1!G2)

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Re,

je te regarde ça dans la matinée,

dans quel coin est ton camping, des fois que je passe dans les parages
Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Re,

La colonne K des fiches client peut être masquée, dans cette colonne K si la date saisie en cellule B1 feuille Comptajour est la même les valeurs sont reportées et totalisées cellule H5, 7 et 8

https://www.cjoint.com/?CFBlshBTsDf
Messages postés
10
Date d'inscription
mercredi 26 juin 2013
Statut
Membre
Dernière intervention
27 juin 2013

merci pour ton aide je regarde ça tout de suite
et pour le camping c dans le couserans à sentein au fin fond de la vallée du biros
encore merci