Envoi de mail avec sendmail

Bonjour,
je n'arrive pas à envoyer un mail en ligne de commande car j'ai un problème durant l'installation de sendmail. J'ai essayé avec postfix mais toujours la même erreur.
Voici le message que j'obtient lorsque j'exécute dpkg -i

dpkg : concernant sendmail-bin_8.14.4-2ubuntu2_i386.deb contenant sendmail-bin :
 sendmail-bin entre en conflit avec mail-transport-agent
  « lsb-invalid-mta » fournit « mail-transport-agent » et est présent ainsi de  « installé ».
dpkg : erreur de traitement de sendmail-bin_8.14.4-2ubuntu2_i386.deb (--install) :
 paquets en conflit - sendmail-bin non installé
Des erreurs ont été rencontrées pendant l'exécution :
 sendmail-bin_8.14.4-2ubuntu2_i386.deb


Merci

9 réponses

  1. Modérateur
    Bizarre ton message, j'ai l'impression qu'apt s'est un peu mélangé les pinceaux.

    Essaye de faire une mise à jour en lançant dans un terminal les commandes suivantes :
    http://doc.ubuntu-fr.org/terminal

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install sendmail


    Si le problème persiste, copie-colle-moi le message d'erreur ainsi que le résultat de :

    cat /etc/apt/sources.list


    Bonne chance
    1
    1. je l'ai installé avec apt-get install. Aprament ça ne marche pas avec un fichier.deb.
      Merci
      1
      1. j'ai migré vers ssmtp car j'ai juste besoin d'envoyer des mail (pas de récéption).
        j'ai les trois messages suivants dans mes fichiers log:
        Jun 28 17:40:01 kbessouda-OptiPlex-790 sSMTP[15092]: Unable to locate mailhub
        Jun 28 17:40:01 kbessouda-OptiPlex-790 sSMTP[15092]: Cannot open mailhub:25
        Jun 28 17:40:02 kbessouda-OptiPlex-790 sSMTP[15110]: Sent mail for root@kbessouda-OptiPlex-790 (221 2.0.0 Service closing transmission channel) uid=0 username=root outbytes=640
        

        voila mon fichier /etc/ssmtp/ssmtp.conf
        #
        # Config file for sSMTP sendmail
        #
        # The person who gets all mail for userids < 1000
        # Make this empty to disable rewriting.
        root=postmaster
        
        # The place where the mail goes. The actual machine name is required no 
        # MX records are consulted. Commonly mailhosts are named mail.domain.com
        mailhub=adresse IP du serveur smtp
        
        
        # Where will the mail seem to come from?
        #rewriteDomain=
        
        # The full hostname
        hostname=kbessouda-OptiPlex-790
        
        # Are users allowed to set their own From: address?
        # YES - Allow the user to specify their own From: address
        # NO - Use the system generated From: address
        FromLineOverride=YES
        


        et mon fichier /etc/ssmtp/revaliases
        # sSMTP aliases
        # 
        # Format:	local_account:outgoing_address:mailhub
        #
        # Example: root:your_login@your.domain:mailhub.your.domain[:port]
        # where [:port] is an optional port number that defaults to 25.
        user:xxxxx@yy.fr:IP serveur smtp


        je ne vois pas d'ou vient le probleme
        merci
        1
        1. Modérateur
          Peux-tu m'indiquer ce que renvoient les commandes de mon précédent message ?
          0
          1. rebonsoir,
            quoique mon MTA soit bien installé je n'arrive pas pas à envoyer des mail vers mon compte yahoo depuis ma machine.
            j'utilise la commande suivante:

            mail -s "ALERT" moncompte@yahoo.fr < message.txt
            


            quand je regarde ma boite mail, je ne trouve aucun message.
            Le fichier log du serveur snmp me renvoie l'erreur suivante:

            Jun 17 15:29:51 kbessouda-OptiPlex-790 sendmail[502]: My unqualified host name (kbessouda-OptiPlex-790) unknown; sleeping for retry
            Jun 17 15:30:51 kbessouda-OptiPlex-790 sendmail[502]: unable to qualify my own domain name (kbessouda-OptiPlex-790) -- using short name
            


            je précise que je suis sur le réseau local de mon entreprise.

            Merci
            0
            1. Modérateur
              Vérifie la valeur que tu as mis pour mailhub. En particulier vérifie que tu n'as pas mis d'espace autour du "="
              https://forums.gentoo.org/viewtopic-t-831758-start-0.html

              Vérifie que l'adresse du serveur smtp que tu as indiqué est correcte et peut-être résolue si tu as mis un hostname

              Exemple :

              nslookup smtp.orange.fr


              Bonne chance
              0
              1. Bonjour,
                J'ai essayé d'utiliser le serveur de yahoo a la place de celui de l'entreprise car le mien a des problèmes. Mais quand j''essai d'envoyer un mail, j'ai l'erreur suivante:
                send-mail: Cannot open mail.yahoo.fr:465
                Can't send mail: sendmail process failed with error code 1
                

                la même chose avec le port 25.
                0