Creation SKU automatique

Fermé
oliviergir Messages postés 4 Date d'inscription mardi 9 avril 2013 Statut Membre Dernière intervention 25 mai 2013 - 24 mai 2013 à 23:41
Raymond PENTIER Messages postés 57013 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 7 février 2023 - 25 mai 2013 à 18:53
Bonjour,

Voici Mon petit probleme!

J'ai un tableaux excell dans laquel j'ai ma liste de produits, dans une des colonne je voudrais creer des SKU ( GIR001 , GIR002 etc .. ) j'ai besoin que ce soit automatique, c'est a dire qu'a chaque fois que je rajoute une ligne Le SKU s'affiche automatiquement!

Pouvez vous m'aider?
PR Avance,
Merci

Olivier
A voir également:

4 réponses

eriiic Messages postés 24496 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 7 février 2023 7 158
Modifié par eriiic le 25/05/2013 à 17:17
Bonjour,

pour faire simple (sans vba), en B2 :
=SI(A2="";"";"GIR" & TEXTE(NBVAL($B$1:B1);"000"))
Si tu saisis une ref en A le GIR suivant s'affiche.
Mais pas question de trier, insérer/supprimer de lignes sans avoir fait un copier-collage spécial valeur sur la colonne B auparavant sinon tes ref se retrouveront avec un nouveau sku.

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
2