Creation SKU automatique

Fermé
Signaler
Messages postés
4
Date d'inscription
mardi 9 avril 2013
Statut
Membre
Dernière intervention
25 mai 2013
-
Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
-
Bonjour,

Voici Mon petit probleme!

J'ai un tableaux excell dans laquel j'ai ma liste de produits, dans une des colonne je voudrais creer des SKU ( GIR001 , GIR002 etc .. ) j'ai besoin que ce soit automatique, c'est a dire qu'a chaque fois que je rajoute une ligne Le SKU s'affiche automatiquement!

Pouvez vous m'aider?
PR Avance,
Merci

Olivier
A voir également:

4 réponses

Messages postés
24261
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2022
7 026
Bonjour,

pour faire simple (sans vba), en B2 :
=SI(A2="";"";"GIR" & TEXTE(NBVAL($B$1:B1);"000"))
Si tu saisis une ref en A le GIR suivant s'affiche.
Mais pas question de trier, insérer/supprimer de lignes sans avoir fait un copier-collage spécial valeur sur la colonne B auparavant sinon tes ref se retrouveront avec un nouveau sku.

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
2
Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 224
Tu sais, en France on n'est pas aussi futés qu'aux USA !
Ainsi on ne sait pas ce que sont des SKU ni des GIR00x ...
C'est pourquoi aucun de nous ne pourra t'aider.
Tu devrais interroger un forum américain.
1
Messages postés
4
Date d'inscription
mardi 9 avril 2013
Statut
Membre
Dernière intervention
25 mai 2013

Bonjour Raymond,

Desole :)

Un SKU est une Reference produit.

J'ai un tableau excel ou tout mes produits sont reference, je voudrais y mettre une autre colonne pour référencer chaque produit avec un code unique qui serrais et qui commencerais par ( GIR0001 ) et puis ( GIR0002 ) etc .... ce que je voudrais savoir c'est comment ces SKU peuvent s'afficher automatiquement a chaque fois que je rentre un nouveaux produit?

J'espere que ma description est un peux plus clair, :)

Merci encore Raymon
Cordialement,
Olivier
0
Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 224
Ainsi que le signale Eric, que je salue ici, nous ne savons pas quel usage tu feras de tes SKU et de ton tableau, ce qui est gênant pour te donner un conseil utile.
On aimerait savoir en particulier si cette référence sera utilisée comme un texte ou comme un nombre ; dans ce dernier cas, il te suffirait en effet d'avoir 1, 2, 3 ... avec le format personnalisé [ "GIR"000 ].
Mais personnellement, plutôt que de créer des automatismes (qui ont parfois des effets pervers), je t'aurais recommandé d'écrire "GIR001" et de recopier vers le bas en "tirant" la poignée et en sélectionnant l'option Recopie incrémentée ...

Bonne continuation !
0