Rsync ne supprime pas les fichiers.zip du dossier de destination

[Résolu/Fermé]
Signaler
Messages postés
54
Date d'inscription
dimanche 16 décembre 2012
Statut
Membre
Dernière intervention
20 janvier 2013
-
Messages postés
54
Date d'inscription
dimanche 16 décembre 2012
Statut
Membre
Dernière intervention
20 janvier 2013
-
Bonjour,

Mon soucis est dans le titre, j'ai cette commande rsync :
rsync -avz --delete --ignore-errors --force --omit-dir-times --stats -h /serveur1 /serveur2/ > /mnt/vol1/log

je créé à partir de windows un fichier zip sur /serveur1

je fais le rsync donc nous avons

/serveur1/fichier.zip /serveur2/fichier.zip


Je peux supprimer le fichier.zip avec un rm /serveur1/fichier.zip

Mais après un rsync, j'ai toujours le fichier.zip dans le dossier de destination /serveur2/

Tout autre fichier se supprime bien
Faut-il spécifier un argument pour les fichier zip ?

Merci

2 réponses

Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 390
Salut,

Non rien à spécifier, je viens de faire un test chez moi et tout c'est bien passé.

Aucune trace dans ton fichier de log ?
Messages postés
54
Date d'inscription
dimanche 16 décembre 2012
Statut
Membre
Dernière intervention
20 janvier 2013
4
Merci, tout va bien, c'était un simple problème d'encodage sur mes fichiers zip, comme c'est tombé sur eux j'ai cru que c'était une erreur de zip....

Là où c'est fort c'est que en premier lieu linux encode le nom du fichier.
Et il ne peut le supprimer car il ne trouve pas le fichier à supprimer (qui a un encodage différent).

Donc le rsync qui m'indiquait un no such file

Merci
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 390
Merci pour le retour ;-)

À la relecture du man rsync j'ai vu qu'il y avait une option "--iconv=CONVERT_SPEC", à consulter le cas échéant...
Messages postés
54
Date d'inscription
dimanche 16 décembre 2012
Statut
Membre
Dernière intervention
20 janvier 2013
4
Oh c'est la moindre des choses
Oui c'est la bonne option :)
Mais il vaut mieux que je change l'encodage en amont sur le mount_smbfs
Merci !