[Suse 10.2] Mayday Mayday Mayday !

Résolu/Fermé
Signaler
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
Salux !

Comme j'ai migré de Fedora Core vers Suse, je reprends ici le cours de mes investigations.

J'avais un problème d'installation de mon imprimante sur un petit réseau familial et je remercie tous ceux qui ont bien voulu me donner un coup de main à ce propos. Néanmoins, il semble qu'il n'y ait pas de solution, car Mr Linux HP n'a tout simplement pas jugé utile de permettre ce type d'installation avec le modèle Photosmart 2575... Pas de bol !

Alors, je continue avec autre chose qui ne fonctionne pas :
Par exemple, ma carte son (du type AC'97 et intégrée à la carte mère) qui refuse obstinément de me délivrer un quelconque décibel dans les esgourdes.

Le système localise la carte et la reconnait dans ses moindres détails. OK
Le contrôleur de volume affiche les contrôles d'une VIA 8237 (ALSA mixer) et me permet de positionner tous les curseurs plein pot ! Parfait.
Les enceintes sont branchées (et fonctionnent très bien sous Windaube) et leur potar n'est pas sur OFF. Nickel.

Détail important : Je n'ai pas tiré sur l'élastic plus que de raison et je ne pense ainsi pas être devenu complêtement sourdingue. LOL

Alors, quoi t'est-ce qu'il a mon 'Linuxou chéri' comme maladie, docteur ?

PS : Je suis toujours aussi débutant avec les commandes en ligne (Konsole). Alors, si je dois taper quelque chose, soyez aimables de le détailler, SVP.

Merci aux bonnes âmes...

3s

37 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Salut,

ouvre une console et tape
grep audio /etc/group;groups $USER;lsmod | grep ac
Il faut taper la commande en utilisateur pas en root.
Affiche le résultat. Merci
0
Messages postés
1272
Date d'inscription
mercredi 1 décembre 2004
Statut
Contributeur
Dernière intervention
16 mars 2008
191
salut


En complement tapes aussi les commandes qui suivent :

lspci | grep audio


cat /proc/asound/cards


histoire de voir si la carte est referencer ici =>

http://www.alsa-project.org/alsa-doc/

0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Yep !

Doucement les gars, j'ai qu'un neurone qui fonctionne.
Voici pour la première commande :

chris@linux-6oq4:~> grep audio /etc/group;groups $USER;lsmod | grep ac
audio:x:17:
users dialout video
af_packet 29320 0
ac 9476 0
ip_conntrack 52960 3 xt_state,iptable_nat,ip_nat
nfnetlink 11032 2 ip_nat,ip_conntrack
snd_ac97_codec 95648 1 snd_via82xx
snd_ac97_bus 6400 1 snd_ac97_codec
snd_pcm 86916 3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd 61188 12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
mbcache 12804 1 ext3
chris@linux-6oq4:~>
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Re,
audio:x:17: veut dire que ton utilisateur ne fait pas partie de groupe audio qui a la permission de lire dans /dev/dsp (le fichier périphérique)

en root tape
usermod -aG audio <NOMUTILISATEUR>
remplace <NOMUTILISATEUR> avec ton utilisateur
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Oops. Pas terrible...

linux-6oq4:~ # usermod -aG audio chris
usermod: invalid option -- a
Try `usermod --help' or `usermod --usage' for more information.
linux-6oq4:~ #


Y'a quekchose qui merdoit...
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
et affiche maintenant
groups <NOMUTILISATEUR>
ensuite teste le son, n'oublie pas de regler le volume
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Tape
usermod --help 
pour voir
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Voilà ce que ça m'a donné :

linux-6oq4:~ # groups chris
users dialout video
linux-6oq4:~ #

et le son ne marche toujours pas.

Je vois le vumètre bouger, mais les baffles restent muettes comme Bernardo.
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Affiche ce que je t'ai demandé au message 7
usermod --help
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
ca donne ca :

linux-6oq4:~ # usermod --help
Usage: usermod ...
usermod - modify a user account

-c comment Set the GECOS field for the new account
-D binddn Use dn "binddn" to bind to the LDAP directory
-d homedir Home directory for the new user
-e expire Date on which the new account will be disabled
-f inactive Days after a password expires until account is disabled
-G group,... List of supplementary groups
-g gid Name/number of the users primary group
-l login Change login name.
-m Move home directory to the new path
-o Allow duplicate (non-unique) UID
-A group,... List of groups the user should be added to
-R group,... List of groups the user should be removed from
-P path Search passwd, shadow and group file in "path"
-p password Encrypted password as returned by crypt(3)
-s shell Name of the user's login shell
-u uid Change the userid to the given number
--service srv Use nameservice 'srv'
-L Locks the password entry for "user"
-U Try to unlock the password entry for "user"
--help Give this help list
--usage Give a short usage message
-v, --version Print program version
Valid services are: files, ldap
linux-6oq4:~ #
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Essaie
usermod -AG audio chris && groups chris && grep audio /etc/group
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Et si ça ne marche pas non plus alors tape
usermod -G users,dialout,video,audio chris && groups chris 
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Ca lui plait pas visiblement ...

linux-6oq4:~ # usermod -AG audio chris && groups chris && grep audio /etc/group
usermod: Too many arguments.
Try `usermod --help' or `usermod --usage' for more information.
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Je ne connais pas Suse
essaie alors ces 2 commandes
usermod -G users,dialout,video,audio chris
groups chris 
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Ca lui plait pas visiblement ...

Tu remarque bien que le Shell surveille ce qu'on essaie de faire, et il gueule toute de suite s'il y a quelque chose qui ne vas pas
et je t'assure qu'il est bien plus bavard qu'une boîte de dialog :-))
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Et voilà !

linux-6oq4:~ # usermod -G users,dialout,video,audio
usermod: Too few arguments.
Try `usermod --help' or `usermod --usage' for more information.
linux-6oq4:~ # chris
bash: chris: command not found
linux-6oq4:~ # groups chris
users dialout video
linux-6oq4:~ #
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
cette fois tu as oublié d'ajouter chris en fin de chaîne

usermod -G users,dialout,video,audio

c'est

usermod -G users,dialout,video,audio chris

0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
Sorry, mais tu sais, moi, j'ai l'impression d'écrire de l'hébreux ou des hyérogliphes là...

linux-6oq4:~ # usermod -G users,dialout,video,audio chris
usermod: `users' is primary group name.
linux-6oq4:~ #
0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
Oups, ici c'est ma faute en ce qui concerne le groups users

usermod -G dialout,video,audio chris


essaie ça et ne perds pas la patience :-))

Ce n'est pas de l'hébreux c'est de l'anglais :-))
0
Messages postés
34
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
17 février 2007
1
C'est marrant, mais j'ai du sauter des pages dans mon manuel d'anglais ! lol

linux-6oq4:~ #
linux-6oq4:~ # usermod -G dialout,video,audio chris
linux-6oq4:~ #


Enfin, j'admire ta patience...
0