Problème installation Dongle Wifi [Résolu/Fermé]

Signaler
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
-
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
-
Bonjour,

Je reviens à la charge avec un nouveau problème...
Après avoir enfin réussi à installer Ndiswrapper, je m'en suis servi pour tenter d'installer une clé wifi en suivant les instructions donné sur le site d'aide d'Ubuntu.
Or, au moment de vérifier si la clé est bien installée en tapant "sudo ndiswrapper -l", je suis censé recevoir comme réponse ceci :
"Installed ndis drivers:
sis163u driver present,
hardware present"

Mais dans mon cas, cela m'affiche :
"install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile install driver described by 'inffile'
-a devid driver use installed 'driver' for 'devid' (dangerous)
-r driver remove 'driver'
-l list installed drivers
-m write configuration for modprobe
-ma write module alias configuration for all devices
-mi write module install configuration for all devices
-v report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
as reported by 'lspci -n' or 'lsusb' for the card"

Je dois avouer ne rien comprendre à ce message.
Est-ce que cela vient du fait que je suis sur la version 12.04 et que la clef n'a été testée que sur les versions inférieures?

Merci d'avance

4 réponses

Messages postés
36299
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 234
Salut,

Or, au moment de vérifier si la clé est bien installée en tapant "sudo ndiswrapper -l"

A tout hasard...
Tu as bien tapé un ELLE minuscule et non pas un UN ?
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Oui, site officiel, version 32Bits (j'ai un vieil ordinateur portable, donc pas besoin de la 64bits)
et sans mousepad ! alors là ... Xubuntu n'est plus ce qu'il était !
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Il est vrai que Nano m'a l'air bien compliqué à coté de mousepad...
Mais bon, tant pis.
Que dois-je faire maintenant?
Redémarre ton ordinateur et regarde si ton wifi fonctionne maintenant .( attends quelques instants avant de cliquer sur l'icône de network manager qu'il ait le temps de détecter ton réseau)
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
ok je redémarre alors
Bonjour,
Plus simple et pour t'éviter de t'arracher les cheveux (les implants capillaires, c'est cher):
http://doc.ubuntu-fr.org/ndisgtk
sudo apt-get install ndisgtk
puis
sudo ndisgtk ou bien menu Système/Administration/Pilotes sans fil Windows

Tu indiques où se trouve le fichier .inf du driver et ndisgtk fait tout le boulot pour toi...

Mais n'oublie pas que les drivers Windows sous linux, ça marche pas à tous les coups !
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Et pourtant je l'ai intallé et utilisé juste avant...
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
C'est peut être un module précis de Ndiswrapper ?
Reprenons : ouvre synaptic et lance une recherche sur le paquet ndiswrapper-common pour vérifier qu'il est bien installé...
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
C'est fait, il est bien la
Bon, alors c'est le module qui n'est pas créé alors revois le post de zipe31 à ce propos.
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Bon et bien ça ne marche toujours pas :(
Lorsque je tape sudo modprode ndiswrapper j'ai encore "Module ndiswrapper not found.
Pourtant, je viens de vérifier, il y a bien ndiswrapper à la fin du fichier modules...
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Je veux bien utiliser vos méthodes mais je ne comprends vraiment pas grand chose (désolé...).
Quand tu me dis : "Tu indiques où se trouve le fichier .inf du driver", je dois faire comment pour faire cela?
Le problème avec toi, c'est que tu réponds rarement à nos questions. Actuellement nous ne savons pas quelles commandes tu as effectivement tapées et leur résultat. Ici, nous ne voyons pas ce que tu fais sur ton clavier et nous ne voyons pas ton écran. Alors, c'est difficile de se faire une idée du pourquoi ça marche pas si on n'applique pas une méthode rigoureuse.
En plus si tu démarres sur des lignes de commandes puis qu'en cours de route tu reprends la méthode graphique sans dire ce que tu as déjà fait, il y a forcément des choses qui vont être faites en double et c'est pas forcément bon pour la suite.
Enfin, je t'ai dit que les drivers Windows sous linux, ça ne marche pas toujours. Parfois y a pas moyen de les faire fonctionner. Si t'as pas le driver pour XP, tes chances sont maigres.

Bon, maintenant je te réponds :
Tu sélectionnes le fichier .inf du driver Windows dans la fenêtre de ndisgtk.
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Je suis vraiment désolé si des questions m'ont échappé :O
Pour sélectionner le fichier .inf, ils me demandent un emplacement.
J'ai d'abord cliqué sur "installer un nouveau pilote" sinon je ne voyais pas de .inf, c'est ce qu'il fallait faire?
Il fallait que tu cherches dans l'arborescence le fichier en question comme quand tu cherches un fichier à ouvrir quoi !
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Bon, j'abandonne...
Impossible de créer ce module ndiswrapper...
Merci quand même pour votre aide (et désolé de t'avoir un peu énervé Jns55...).
Bonne fin de journée
Messages postés
662
Date d'inscription
lundi 8 août 2011
Statut
Membre
Dernière intervention
3 mars 2016
20
Finalement j'ai réussi à installer le dongle wifi !

J'ai vu sur des forums de Debian que certains avaient plus ou moins le même problème.
Je suis alors passer par Module-assistant et après quelques minutes de trifatouillage, la clé à enfin fini par s'allumer.

Bon, après j'ai eu une erreur Grub au démarrage (lorsque je branchais la clé wifi sous une autre version d'ubuntu, cela bloquait la souris, d'ou mon intention de changer de version Ubuntu, mais la le problème a eu lieu de nouveau et j'ai du éteindre en restant appuyé sur Power).

enfin bref, le module ndiswrapper n'était pas reconnu par la commande Modprobe d'ou l'utilité de module-assistant.

Sur ce, bonne journée.

cordialement,