Problème de compilation avec Qt

[Résolu/Fermé]
Signaler
Messages postés
59
Date d'inscription
mardi 13 juillet 2010
Statut
Membre
Dernière intervention
30 décembre 2012
-
 Jezuz -
Bonjour à tous !!!

J'ai quelques problèmes avec le tutoriel (https://openclassrooms.com/fr/courses/1894236-programmez-avec-le-langage-c sur l'utilisation de Qt en C++.

Tout d'abord, sachez que j'ai téléchargé et installé le Qt SDK sur mon ordinateur (sous Windows 7) avec l'installeur offline.

Ensuite, en suivant le tutoriel comme un bon élève (moi, bon élève, lol) j'ai ouvert Qt Creator, créé un nouveau projet ("Autre projet" -> "Projet Qt vide") pour ensuite arriver à la fenêtre de codage.

Après, toujours en suivant le tuto, j'ai créé un nouveau fichier source C++ nommé "main.cpp" dans mon projet, j'ai testé le bout de code proposé pour créer le widget avec le bouton "Salut les Zéros, la forme ?" et j'ai appuyé sur la flèche verte pour compiler le projet. Pas de problème, ma fenêtre s'affiche !!!

C'est ensuite que ça se complique : j'ai essayé de compiler pour le projet le diffuser et pouvoir l'executer en cliquant dessus l'exécutable. Comme dans le tuto (https://openclassrooms.com/fr/courses/1894236-programmez-avec-le-langage-c#ss_part_4), j'ai copié les trois dll (que j'ai galéré a trouvé car le dossier spécifié dans le tuto n'existait pas...) dans le même répertoire que l'exécutable mais dès que j'ai essayé de lancer le programme, il m'a dit qu'il me manquait encore certaines dll.

J'ai alors rajouté toutes les dll que le programme me demandait mais lorsque j'ai lancé l'application, un téléphone s'est affiché avec mon bouton "Salut les Zéros, la forme ?" sur l'écran o_O .

Voici l'image du téléphone qui s'affiche

https://qt.developpez.com/doc/4.6/images/qtcreator-symbian-components-example-simulated.png

Après quelques recherches sur internet, j'ai trouvé qu'il s'agissait du Qt Simulator pour simuler le fonctionnement du programme sur un téléphone. Or moi, je veux simplement faire tourner mon programme sur Windows et non dans un téléphone !!!

Je voudrais donc bien savoir s'il s'agit d'un problème de réglages ou de manipulation, d'un problème de mauvaise version ou d'un problème dû au nouvelles mises à jour de Qt Creator depuis la publication du tutoriel (dans ce cas, si vous avez une version plus ancienne comme celle du tutoriel qui fonctionne, je suis preneur) !!!

Si une âme charitable pouvais me donner LA solution pour afficher ma fenêtre correctement, je lui en serait très reconnaissant ^^ !!!

1 réponse

Messages postés
59
Date d'inscription
mardi 13 juillet 2010
Statut
Membre
Dernière intervention
30 décembre 2012
17
EDIT : C'est bon, j'ai résolu le problème, j'avais copié les dll du dossier "Qt simulator" au lieu du dossier "Desktop".

Voici le répertoire où j'ai trouvé les bonnes dll : C:\QtSDK\Desktop\Qt\4.7.4\mingw\bin
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

merci beaucoup mec,
J'avais complètement oublié ce problème que j'avais rencontré, et grâce à la recherche d'un autre, un ancien a été comblé