[Disque externe] Partition qui ne monte pas [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 19 décembre 2006
Statut
Membre
Dernière intervention
23 décembre 2006
-
Messages postés
496
Date d'inscription
mardi 4 juillet 2006
Statut
Contributeur
Dernière intervention
5 mai 2010
-
Kikoo

Mon pedigree : iMac G5 - Disque externe LaCie d2 300 Go FW et USB acheté il y a deux mois - OS X.4.8

Ma maladie : J'ai formaté mon disque externe en 2 partitions. Une en FAT32 pour itunes et une en HFS+ pour tout le reste. J'ai changé les autorisations pour qu'un utilisateur d'un autre compte de mon Mac ne puisse aller sur la partition HFS+ (depuis son compte avec pomme i). Ca fonctionnait très bien avant... Puis maintenant, seule la partition en FAT32 monte sur le bureau des deux comptes et plus du tout celle en HFS+. Disk Utility affiche les 2 partitions, mais celle en HFS+ reste avec une icone "blanche" dans l'utilitaire. Démonter, monter... Vérification OK... Réparer : il n'y a rien à réparer, réparer les autorisations ok, zapper la pram ok... Bref, aucun conseil du forum ne marche et je deviens fou !!!

Quelqu'un aurait-il une idée pour récupérer cette partition (évidement pleine de données) ?

Merci à tous

4 réponses

Messages postés
9323
Date d'inscription
lundi 13 septembre 2004
Statut
Modérateur
Dernière intervention
28 février 2020
347
tu dis que tu arrives à le monter avec Utilitaire de Disque ?
Messages postés
5
Date d'inscription
mardi 19 décembre 2006
Statut
Membre
Dernière intervention
23 décembre 2006

La partition HFS+ apparait comme une "feuille blanche au coin cornée" dans Utilitaire de Disque, et la partition FAT32 comme une icône classique de disque dur (qui elle, apparait sur le buro). Il est noté à son sujet : - Format : Mac OS étendu- Respect des privilèges : NON - capacité : 130 Go (la taille normale de cette partition) - nombre de dossiers et fichiers : 0 - et plus aucune info sur tout le reste. Je peut démonter cette partition, et l'icône redevient une icone de disque dur DANS utilitaire de disque, et son nom est grisé. Si je fais MONTER LE DISQUE, l'icone redevient une feuille blanche et ne monte pas sur le buro...

C'était un peu long comme descriptif, mais si ça peut te donner une idée de la maladie de mon disque qui fonctionnait très bien avant, avec ses deux partitions.

J'ai essayé DiskWarrior, qui dit que le directory de la partition HFS doit être reconstruite et remplacée. Fort bien. Action : rebuild ! Résultat : c'est successfully rebuilt pour DiskWarrior, mais en fait rien n'a changé !!! Toujours pas de partition HFS. Et si je relance DiskWarrior, celui-ci veux de nouveau reconstruire la bête...

J'ai essayé de changé les autorisations avec SuperGetInfo, LaCie Backup ne veux rien entendre, et MountMe ne reconnais pas la partition !!!!

Bouuuuuuuuuu.
Messages postés
9323
Date d'inscription
lundi 13 septembre 2004
Statut
Modérateur
Dernière intervention
28 février 2020
347 >
Messages postés
5
Date d'inscription
mardi 19 décembre 2006
Statut
Membre
Dernière intervention
23 décembre 2006

As-tu essayé de brancher ton disque sur un PC ?
Messages postés
5
Date d'inscription
mardi 19 décembre 2006
Statut
Membre
Dernière intervention
23 décembre 2006
>
Messages postés
9323
Date d'inscription
lundi 13 septembre 2004
Statut
Modérateur
Dernière intervention
28 février 2020

Non, je n'ai pas essayé après la panne... Je ne vois pas bien en quoi ça peut faire avancer le schmilblik, sachant que la partition HFS est purement Mac et donc totalement illisible sur un pc. C'est l'intérêt d'avoir les deux partitions : une pour passer des documents de MAC à PC, et l'autre devant recevoir (au futur antérieur) un OS X de secours. Avant ma panne, les PC reconnaisaient la FAT32 et pas la HFS+. L'informatique étant un grand mystère insondable et chaotique, j'essaierai cependant.
Messages postés
5
Date d'inscription
mardi 19 décembre 2006
Statut
Membre
Dernière intervention
23 décembre 2006

Pour info pour ceux qui ont un problème similaire, voilà la solution que j'ai appliquée.
J'ai utilisé Data Rescue et la récupération des fichiers s'est faite sans problème. :-)
Utilitaire de disque > effacer la partition > format MAc OS étendu (journalisé)...
Ca marche ! Je redémarre le DD. De nouveau qu'e la seule partition FAT32 qui apparait :-(
Re-formatage mais cette fois ci en non journalisé...
Ca à l'air de marcher correct, même après redémarrage.

LA JOURNALISATION EST-ELLE INTERDITE AUX DD EXTERNES ?
Qu'apporte t-elle de plus qu'unf ormatage non journalisé ?
Si quelqu'un a une réponse, je suis preneur.
Messages postés
1
Date d'inscription
lundi 16 avril 2007
Statut
Membre
Dernière intervention
16 avril 2007

hello !

Voila je continue sur ce post vu que j'ai exactement le même problème. En effet suite à quelques manip (stupides) une partition de mon DD ne monte plus sur le bureau. Evidemment c'est la partition que je n'avais pas encore sauvegardé...normal, quoi...

Et tout comme tagada lorenzo, cette partition reste invisible, sauf dans l'utilitaire de disque ou la présence de cette partition se manifeste par une icone de feuille blanche corné. Donc pas moyen de faire un pomme i pour atteindre les autorisations. je me tâte donc a formater en non journalisé. Ca marche vraiment sans perdre les données ? Disons que ça me ferait bien mal de tout perdre.

Si quelqu'un pourrait me confirmer une solution ou en apporter une autre qui me permettrait de retrouver toutes mes données intactes.

Merci d'avance ;-)
Messages postés
496
Date d'inscription
mardi 4 juillet 2006
Statut
Contributeur
Dernière intervention
5 mai 2010
115
bonjour

Comment pourrais je faire pour forcer le montage d'une partition Mac (Os 8.1) san perdre toutes les données qu'il y avaient dessus

Si possible en se servant d'un utilitaire sur diskette 1M44 plutot que d'un cd


Merci d'avance