Excel, report et calcul auto [Fermé]

Signaler
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012
-
Messages postés
16448
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
11 mai 2021
-
Bonjour,

J'ai besoin de reporté chaque nom différent dans un même tableau et de calculer combien de fois il apparaît dans le tableau de base, sans entrer de critères car j'ai beaucoup de nom.
Est-ce possible ?

3 réponses

Messages postés
16448
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
11 mai 2021
3 170
Bopnjour,

Oserais-je me permettre de conseiller encore une fois à engelyk d'utiliser un tableau Croisé dynamique, ou autrement dit, pourquoi faire simple quand on peut faire compliqué ?
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 476
J'avais pô vu les autres posts.

Peut-être que si on avait une vue globale de la problématique, on pourrait donner une aide un peu plus circonstanciée ?
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

Je ne sais pas faire de tableau croisé dynamique. A quoi cela sert-il ?
J'ai un autre souci, peut-être qu'un tableau croisé dynamique m'aiderait, je l'ai posté sur un autre forum :
https://www.excel-downloads.com/threads/somme-dune-cellule-selon-plusieurs-criteres-jour-heure.178179/#post1095530
Messages postés
16448
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
11 mai 2021
3 170
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 476
Oui. Avec la formule =NB.SI() (=COUNTA() en anglais)



Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

C'est possible d'avoir un peu plus de détails ?
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

Avec la formule NB.SI je suis obligé de rentrer des critères ?
Je ne peux pas rentrer de critères, j'ai 500 noms différents.
Aurais-tu une autre solution ?
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 476
Ben, en fait, c'est moi qui ai besoin de plus d'infos :-)

A lire ton second post ci-dessous ta question de base était mal formulée: tu ne veux pas compter le nombre d'apparition des noms, tu veux additionner les valeurs de la colonne "B". Me trompé-je ?

Donc, pour ton tableau final:

1. Créer une liste avec des noms uniques dans la colonne A:
- Sélectionne toute ta colonne "A" dans ton tableau de base
- Cliques sur "Données", puis sur Filtre et ensuite sur "Filtre avancé".
- Dans les options clique sur "Copier à un autre endroit" et coche la case "Valeurs uniques"
- Choisis ou tu veux commencer ta seconde table et clique sur Ok.
- Pour l'exemple, ton tableau de base est sur la Feuil1 et ton tableau final sur la Feuil2

2. Compter les nombres de la colonne B sur base de la colonne A:
- Si le premier nom à compter apparaît dans la case A1, dans la case B1 de la feuil2 tu écris la formule suivante: =SOMME.SI(Feuil1!A1:A6;A1;Feuil1!B1:B6)
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

Le filtre ne fonctionne pas, il me met un message d'erreur
"Cette commande requiert au moins 2 lignes de données source. Vous ne pouvez pas l'utiliser sur une seule ligne de données. Essayé la méthode suivante : ..."
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 476
Attention tu dois sélectionnes la colonne, pas la ligne.
Mets un titre au dessus de tes colonnes (par exemple "nom" en A1 et "nombre" en B1.
Fais le copier/coller et enlève les titres ensuite.
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

En gros, tableau de base

A1 : DUPONT Marie B1 : 2
A2 : DUBOIS Sandrine B2 : 1
A3 : DUPONT Marie B3 : 3
A4 : MARTIN Olivier B4 : 2
A5 : DURANT Bertrand B5 : 4
A6 : DURANT Bertrand B6 : 1

Tableau final

A1 : DUPONT Marie B1 : 5
A2 : DUBOIS Sandrine B2 : 1
A3 : MARTIN Olivier B3 : 2
A4 : DURANT Bertrand B4 : 5