Formule SOMME.SI.ENS erreur date [Résolu/Fermé]

Signaler
-
 Marine63 -
Bonjour,

Je suis en train de travailler sur un registre du personnel via excel à partir duquel je soutire tout un tas d'informations notamment la suivant pour laquelle j'ai un problème :

Je souhaite avoir les ETP par catégorie et par mois.
J'ai donc utilisé une formule SOMME.SI.ENS car j'ai pleins de critère de sélection.... (catégorie, entité, type de contrat...)
Pour avoir mes calcules par mois j'ai intégré dans ma formule les dates, par ex:
"<=31/03/2011" et ">=01/03/2011". Et ma formule fonctionne super bien.

Mon problème maintenant c'est que j'aimerai automatisé ces dates pour que d'une année sur l'autre nous n'ayons pas besoin de modifier toutes les formules... Mais seulement 2 cellules....
Donc j'aimerai faire référence à 2cellules dans lesquelles seraient notée les dates : "<=AA1" (pour 01/03/2011) et ">=AA2" pour 31/03/2011, et là ca ne prend plus en compte ce critère de date dans mes résultats....

PANIQUE à bord !! j'ai au moins 25h de travail dessus....bouhhh :(
Merci d'avance pour votre aide !!!

7 réponses

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 307
Bonjour,

Tu peux donner un "nom" à tes cellules contenant des dates de référence et utiliser ceux-ci dans tes formules.

par exemple tu appelles la cellules A1 qui contient la date 01/03/2011, D_2011_03 et tu utilises ce nom dans tes formules par exemple : =si(B3>D_2001_03;0;1).

Remarque : éviter les sigles comme ETP, incompréhensible pour la plupart des gens. Envoyer un petit exemple pour pouvoir plus rapidement cerner le problème via par exemple cjoint.com

Bonne journée

pépé
Merci beaucoup pour la formule je vais tenter ça de suite.
et Merci pour les remarques, je ne suis pas une grande habituée des forums !!

A plus tard (si ca ne fonctionne tjrs pas... ;-)
Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 113
Bonjour

un petit exemple avec prise en compte du choix de l'année et du mois avec sommeprod (xl2003) à traduire en somme.si.ens

https://www.cjoint.com/?3LhlaYeAflf
Ca ne fonctionne pas..... Pépé35530 Ca ne change rien, comme ma précédente formule !
Et je n'arrive pas à ouvrir votre fichier michel_m !!

Mon tableau est trop conséquent avec trop d'informations confidentielles pour le faire passer via "cjoint.com". En revanche je peux vous mettre ma formule pour vous montrer où ça ne va pas....

=SOMME.SI.ENS('Registre U du personnel'!$X$9:$X$1562;'Registre U du personnel'!$B$9:$B$1562;"Pharm'adis";'Registre U du personnel'!$Q$9:$Q$1562;"TH-EO";'Registre U du personnel'!$AE$9:$AE$1562;$G$3;'Registre U du personnel'!$U$9:$U$1562;">=01/02/2011";'Registre U du personnel'!$T$9:$T$1562;"<=28/02/2011")+SOMME.SI.ENS('Registre U du personnel'!$X$9:$X$1562;'Registre U du personnel'!$B$9:$B$1562;"Pharm'adis";'Registre U du personnel'!$Q$9:$Q$1562;"TH-EO";'Registre U du personnel'!$AE$9:$AE$1562;$G$3;'Registre U du personnel'!$U$9:$U$1562;"")

Les dates en gras sont celles que j'ai rentré manuellement et que je souhaiterai automatisé...
Sinon ce n'est pas grave il faudra que je fasse ma modif tous les ans.

merci encore pour votre aide !
Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 113
dans AA1 tu marques l'année dans AA2 tu marques le mois (2 pour février,3 pour Mars...)


...Registre U du personnel'!ANNEE($U$9:$U$1562);AA1;'Registre U du personnel'!MOIS($U$9:$U$1562);AA2;....
idem pour la colonne T

mais comme l'a indiqué pépé, nommes les colonnes de ton tableau: tu seras nettement gagnante pour écrire ou lire ta formule
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 307
Bonjour,

Dans une cellule tu tapes ta date 01/02/2011 au format date.
La cellule étant active, clique sur "Formules", "Définir un nom" et taper par exemple dans la zone définir un nom : date_1.

Ensuite dans ta formule remplacer >=01/02/2011 par >=date_1 sans guillemets.

A+

pépé
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 724
Bonjour

j'arrive peut être comme un cheveu sur la soupe (c'est bon l'hiver) mais dans les codes SOMME.SI, NB.SI et ceux qui en découle,(et en fait, les codes qui utilisent le point virgule comme séparateur ) la formule > ou < doit s'écrire quand elle fait référence à une cellule:
=NB.SI(champ;">"&cell)
le égal, lui, est pris par défaut derrière le point virgule
avec le signe entre guillemets, le signe & et ensuite l'adresse de cellule.

crdlmnt:
Pépé sans guillemets ca ne prend pas ma formule...

Bonjour VAUCLUSE et MERCI VAUCLUSE !!!!! Ca fonctionne !!!!

Merci à tous pour vos multiplies réponses, on en apprend tous les jours sur ces logiciels !!!

Merci merci merci!!!