Faire un calcul sans tenir compte du texte [Résolu/Fermé]

Signaler
Messages postés
14
Date d'inscription
vendredi 4 août 2006
Statut
Membre
Dernière intervention
5 décembre 2011
-
Messages postés
14
Date d'inscription
vendredi 4 août 2006
Statut
Membre
Dernière intervention
5 décembre 2011
-
Bonjour,

Je travail sur l'élaboration d'un planning et rencontre quelques difficultés.

J'ai trouvé une formule me permettant de calculer le nombre de "RH" dans une semaine.
=NB.SI(B2:C8;"RH")

Le problème s'est qu'une fois les "RH" rentré dans mon tableau, mon calcul des heures effectuées par semaine "Total hebdo" ne fonctionne plus, car il ne veut pas prendre en compte les données alphabétique.
=(C2-B2)+(C3-B3)+(C4-B4)+(C5-B5)+(C6-B6)+(C7-B7)+(C8-B8)

Existe t'il une formule qui me permettrait d'effectuer ce calcul ou bien de compter les "Rh" pour 0.

J'ai essayer cette formule : mais je ne souhaite pas avoir de SOMME mais la différence entre les heures effectuées et compter les RH pour 0

=SOMME(B2:C8)+SOMMEPROD(N(ESTTEXTE(B2:C8)))

voici mon tableau :


Heure début Heure fin
LUNDI 10:00 17:00
MARDI RH
MERCREDI RH
JEUNDI 10:00 22:00
VENDREDI RH
SAMEDI RH
DIMANCHE 12:00 23:00
Total Hebdo =(C2-B2)+(C3-B3)+(C4-B4)+(C5-B5)+(C6-B6)+(C7-B7)+(C8-B8)
Nbre RH =NB.SI(B2:C8;"RH")

Total Hebdo2 =SOMME(B2:C8)+SOMMEPROD(N(ESTTEXTE(B2:C8)))

Merci d'avance pour votre aide



2 réponses

Messages postés
1900
Date d'inscription
jeudi 1 décembre 2011
Statut
Membre
Dernière intervention
16 février 2012
617
Chez moi un simple :

=SOMME(C2:C8)-SOMME(B2:B8)

fonctionne
Messages postés
14
Date d'inscription
vendredi 4 août 2006
Statut
Membre
Dernière intervention
5 décembre 2011

effectivement je me suis fais des noeuds au cerveau pour rien
c'était si simple ! merci
Messages postés
20724
Date d'inscription
mercredi 18 avril 2007
Statut
Contributeur
Dernière intervention
15 avril 2021
1 600
tu peux pas faire un SOMMESI en mettant la condition valeur différente de "RH" ?
(ou en utilisant le ESTTEXTE que tu as déja trouvé)