Point de montage partition de stockage

Résolu/Fermé
juju - 3 sept. 2006 à 14:04
mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
- 6 juil. 2010 à 01:15
bonjour,
j'ai un espace vide d'une dizaine de gigas et je voudrais en faire une partition de stockage. mais je ne sais pas quel point de montage choisir... /home est déjà pris.
merci pour votre aide
bonne journée

10 réponses

mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
7 421
11 sept. 2006 à 09:07
La solution est très simple. Il faut rajoute l'option users (avec un s) dans les options de /etc/fstab concernant /dev/hda8. Ainsi un utilisateur pourra monter démonter la partition à volonté avec ses droits.

Si tu mets auto la partition sera monté par démarrage. Comme tu n'as pas précisé par qui, la partition sera montée en root. Il faudrait alors être root pour la démonter. Il faut donc ne pas la monter au démarrage (remplace l'option auto par noauto) :
/dev/hda8 /mnt/stockage ext3 noauto,user,users,exec,rw,sync 1 2

... ou la monter avec le bon utilisateur. Par exemple si c'est l'utilisateur tapir :
/dev/hda8 /mnt/stockage ext3 auto,user,users,exec,rw,sync,uid=tapir 1 2

Pour konqueror, il est en effet lancé avec les droits utilisateur (tapir par exemple) et non root. Il ne faut pas lancer konqueror en tant que root, car le graphique en root, c'est mal.

Bonne chance
1
mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
7 421
3 sept. 2006 à 15:27
Il suffit de créer un autre point de montage. En root :
mkdir -p /mnt/stockage

Puis d'ajouter une ligne adéquate dans /etc/fstab. Par exemple pour une partition en vfat, accessibles à tous les utilisateurs, et correspondant à la partition /dev/hdb1 :
/dev/hdb1   /mnt/stockage   vfat   user,users,auto,rw,exec   0  0

Au reboot la partition apparaîtra dans /mnt/stockage mais tu peux d'ores et déjà la monter en tapant (en utilisateur) :
mount /mnt/stockage

Bonne chance
0
bonjour,
mille excuses pour ma réponse tardive, j'étais en vadrouille...

alors en fait j'ai utilisé l'outil graphique de mandriva pour monter ma partition. elle est bien montée mais j'ai un soucis, je ne peux pas écrire dessus.

pourtant j'ai modifié mon fichier fstab dans le bon sens je crois. je te colle le fichier, peux tu me dire ce qui ne va pas s'il te plaît?

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/hda1 / ext3 noatime 1 1
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda7 /mnt/kubuntu ext3 defaults 1 2
/dev/hda8 /mnt/stockage ext3 auto,user,exec,rw,sync 1 2
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

c'est la partition hda8. une dois montée, mandriva m'avait mis par défaut comme options de montage noatime. je pouvais pas écrire alors j'ai essayé avec defaults sans résultats et pour finir les options que tu vois.

merci pour ton aide
a+
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
8 sept. 2006 à 18:19
Salut,

le fait qu'une partition est montée en LectureEcriture veut dire que tu peut lire et écrire sur la partition mais ne veut pas dire que tu peux lire ou écrire dans un fichier qui n'a pas les droits nécessaires.

affiche ls -al /mnt après le montage de ta partition

lami20j
0
salut,

# ls -al /mnt
total 20
drwxr-xr-x 5 root root 4096 sep 8 20:54 ./
drwxr-xr-x 19 root root 4096 sep 8 20:50 ../
drwxr-xr-x 2 root root 4096 sep 2 15:54 cdrom/
drwxr-xr-x 21 root root 4096 sep 8 19:36 kubuntu/
drwxr-xr-x 3 root root 4096 sep 8 16:28 stockage/

je ne peux rien faire sur stockage, je peux pas créer de dossier, de fichier texte ou copier d'une autre partition sur celle ci. je peux juste y accéder. j'ai rien sur cette partition pour le moment, je l'ai formaté avant de la monter.

merci de ton aide
0
chown -R ton_nom /mnt/*
0
(en root *)
0
mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
7 421
6 juil. 2010 à 01:14
Ça n'avance à rien autant être root et en plus on n'a pas forcément envie de changer les droits sur le système de fichiers s'il comporte des droits. C'est juste les options de montage qui sont mauvaises. On peut éventuellement passer à mount les options user ou users (option -o) ou via /etc/fstab.
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
8 sept. 2006 à 21:03
Même pas en root?

lami20j
0
en root je peux créer un dossier mais je ne peux pas ensuite supprimer le dossier... j'ai le message "le protocole trash ne gère pas la création de dossiers". par contre je peux supprimer les fichiers.
0
rectificatif: en root je peux supprimer un dossier mais en console... pas sous konqueror. c'est quoi ce bins?
0
mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
7 421
6 juil. 2010 à 01:14
C'est normal konqueror n'est pas lancé avec des droits root (et n'est pas sensé l'être)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
8 sept. 2006 à 21:35
Puisque konqueror tu le démarre en tant qu'utilisateur et pas en tant que root.

lami20j
0
non, c'est en lançant konqueror en root que j'ai le message erreur quand je veux supprimer un dossier...
0
mamiemando
Messages postés
31452
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
25 septembre 2022
7 421
6 juil. 2010 à 01:15
C'est normal il ne faut pas lancer d'application en root. Le problème ne se pose que si le média a été monté avec des droits root.
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
8 sept. 2006 à 21:40
Regarde ici securite droits d acces gnu linux pour les droits d'accès.

lami20j
0
personne n'a une idée?...
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
9 sept. 2006 à 11:03
Salut,

pour être sur.

Comment tu fait pour lancer konqueror?

Tu es connecté sour le compte root en mode graphique?!

Quand tu es sous konqueror, fait un clic droit sur le dossier et regarde les droits.

lami20j
0
re,
non j'ai lancé konqueror exeptionnellement en root (après m'être déconnecté du net) pour voir ce que ça donnait. mais c'est prévu comme utilisation sous mandriva, il y a un lien konqueror mode su dans le menuk.
sinon, je n'ai aucun dossier sur stockage seul root peut en créer...
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
9 sept. 2006 à 11:28
Re,

seul root peut en créer..

même si tu fait un
chmod -vR 1707 /mnt/stockage/
en tant que root?!

lami20j
0
c'est mieux déjà... je peux maintenant créer un dossier, copier des fichiers etc.

par contre, je ne peux supprimer les dossiers créés qu'en console! toujours ce message "le protocole trash ne gère pas la création de dossier".

bon c'est pas la fin du monde mais pourquoi j'ai ce message?!
merci de ton aide
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
9 sept. 2006 à 12:22
Regarde ça http://www.infos-du-net.com/forum/249014-10-impossible-supprimer-dossier

lami20j
0
ok, je vais voir ton lien.
en tout cas merci beaucoup pour ton aide. c'est pas grave ce message, ce n'est que les dossiers nouvellement créés que je dois supprimer en console (ce qui ne m'ennuie pas spécialement). pour le reste ça roule.
bon week end
a+
0