Calcul de moyenne si

Résolu/Fermé
tjolan Messages postés 11 Date d'inscription dimanche 22 février 2009 Statut Membre Dernière intervention 29 décembre 2013 - Modifié par tjolan le 26/10/2011 à 15:26
tjolan Messages postés 11 Date d'inscription dimanche 22 février 2009 Statut Membre Dernière intervention 29 décembre 2013 - 26 oct. 2011 à 16:37
Bonjour,
je dispose d'un fichier excel avec un onglet où se situe mes données et je souhaite insérer un onglet pour y synthétiser quelques informations (sans forcément passer par un tableau croisé dynamique).
Dans cet autre onglet je souhaite calculer une moyenne d'âge par genre (ex homme/femme).
J'ai pensé à une moyenne si mais je bute sur la construction.
Pourriez vous m'éclairer ?
En vous remerciant.


3 réponses

g Messages postés 1263 Date d'inscription vendredi 23 avril 2004 Statut Membre Dernière intervention 15 mai 2017 574
26 oct. 2011 à 16:12
Bonjour,

Avec le genre en colonne B et l'âge en colonne A :
=SOMMEPROD((B2:B18="homme")*(A2:A18))/SOMMEPROD((B2:B18="homme")*1)

Et tu remplace homme par femme ou par la référence d'une cellule.

Bonne soirée.
2
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
26 oct. 2011 à 16:33
Bonjour

avec MOYENNE.SI:
=MOYENNE.SI(champ sexe;"type sexe";champ valeur)
tout simplement
champ sexe: champ où est indiqué le sexe
type sexe: entre guillemets, le code qui définit homme ou femme, ou, sans les guillemets, l'adresse d'une cellule où ce code sera entré
champ valeur: champ des nombres pour le calcul.
Bonne chance
c rdlmnt
2
tjolan Messages postés 11 Date d'inscription dimanche 22 février 2009 Statut Membre Dernière intervention 29 décembre 2013
26 oct. 2011 à 16:37
Merci beaucoup pour votre aide.
Ça fonctionne.
0