Recherche conditionnelle sous open office

Fermé
-
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
-
Bonjour,

J'ai open office V3.
J'utilise la fonction RECHERCHEV mais quand la valeur n'a pas été trouvée je veux affecter une autre cellule, du style :
=SI(RECHERCHEV(C1;Comptes.$A$1:$B$4;2;0)=VRAI;RECHERCHEV(C1;Comptes.$A$1:$B$4;2;0);D1)
Mais ça ne marche pas.
quelqu'un a une idée ?
cdlt
Dominique

2 réponses

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 374
Bonjour,

Voici une formule qui semble fonctionner avec des valeurs numériques en colonne B :

=SI(ESTNUM(RECHERCHEV(C1;A1:B4;2;FAUX))=FAUX;D1;RECHERCHEV(C1;A1:B4;2;FAUX))

Si la colonne B comporte du texte, on doit pouvoir remplacer la fonction ESTNUM par la fonction ESTTEXTE, mais je n'ai pas vérifié.

Cela fonctionne également avec la fonction ESTTEXTE

A+

pépé
Merci beaucoup, vous m'enlevez une grosse épine du pied.
Cordialement.
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 374
Bonne journée,

pépé