Carte wifi non reconnue Backtrack 3 Usb [Résolu/Fermé]

Signaler
-
 Diesel -
Bonjour,

J'ai installer Backtrack 3 (version boot usb) sur une clée, j'arrive à booter sur celle-ci correctement, interface graphique: tout est ok.

Le problème est que je n'arrive pas à activer le wifi, il semble que ma carte wifi ne soit pas reconnue pas le système.

Ma carte: Atheros AR9285

Je ne sais pas comment la faire reconnaitre au système, pourriez-vous m'aider ?

4 réponses

Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 133
Il faudrait récupérer les données le la carte via lspci.

Pourquoi avoir choisi BackTrack ???
Tu pourrais me dire comment faire ça ?

Backtrack car je veux faire des tests sur mon réseau.
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 133
lspci | grep Network
Normalement Cette carte est gérée par le pilote ath9k, libre et inclus dans le noyau linux depuis la version 2.6.27.
A voir la version du noyau dans BT 3...
Tape iwconfig dans une console et regarde si tu as une ligne wlan0 ou wlan1.
Tu sauras tout de suite si linux a reconnu ta carte ou non.
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 133
Je me demande si BT3 n'est pas encore basée sur Slackware ! Elle date de juin 2008, si le noyau n'a pas été mis à jour, il doit encore être en version 2.6.25, ce qui expliquerait que la carte n'est pas reconnue ;)
J'ai testé Backtrack 4 sous une machine virtuelle (wvmare, en mode bridge), même problème "no wireless extension"
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 133
En machine virtuelle, c'est normal, les périphériques physiques ne sont jamais reconnus (puisqu'ils sont virtualisés...)
Ma carte n'est pas reconnue, iwconfig me donne "No wireless extensions"

J'ai tenté de faire airmon-ng start wlan0 , sans résultat.

J'ai utilisé la commande lspci:
Il a bien trouvée ma carte atheros, suivit de "Inknow device 002b".

Toujours pas de wifi.
Passe à BT 5 !
Le truc c'est que j'ai une version de bactrack spéciale pour les petites clées usb, je n'ai pas trouvé d'équivalent en version backtrack 4 ou 5.
J'ai fait un cd de Backtrack 4, j'ai booté dessus et il m'a bien reconnu ma carte wifi.

J'ai juste dût l'activer avec start NetworkManager.

Résolut.