Formule "égal tout ou partie d'une liste"

Résolu/Fermé
Signaler
Messages postés
45
Date d'inscription
samedi 25 avril 2009
Statut
Membre
Dernière intervention
27 juin 2021
-
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
-
Bonjour,

Je souhaiterais savoir si vous connaissez une formule qui permette de dire si la valeur d'une cellule est égale à tout ou partie d'une liste.

Exemple :
La liste se présenterai comme suit :

A1 = Camion blanc
A2= Voiture rouge
A3 = moto verte
Etc.

Je voudrais que si on entre une valeur dans la cellule B1 et que celle-ci est égale à tout ou partie de l'une des valeurs de la liste (exemple : "camion", "rouge", "moto verte") alors la cellule C1 me mettre "VRAI" sinon "FAUX".

Est-ce que vous avez une idée ??

Merci d'avance !!


4 réponses

Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
6 136
Bonjour
Des valeurs de la liste ou de la cellule en ligne?

pour la cellule en ligne
essayez ceci si j'ai bien compris, en C1:
=SI(NB.SI(A1:A1;"*"&B1&"*")>0;VRAI;FAUX)

pour tout le champ(de 1 à 100 pour l'exemple)
=SI(NB.SI(A1:A100;"*"&B1"*")>0;VRAI;FAUX)

crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
2498
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
10 novembre 2021
1 010
Bonjour,
Une esperluette (&) est partie pêcher le poisson du jour dans la seconde formule.
=SI(NB.SI(A1:A100;"*"&B1&"*")>0;VRAI;FAUX)
Pourquoi ne pas simplifier:
=NB.SI(A1:A100;"*"&B1&"*")>0
Messages postés
45
Date d'inscription
samedi 25 avril 2009
Statut
Membre
Dernière intervention
27 juin 2021

Apparemment ça marche pas !
Messages postés
2498
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
10 novembre 2021
1 010
Essayez de nous dire ce qui ne fonctionne pas et dans quelles circonstances.
Pour moi le seul dysfonctionnement est l'affichage "VRAI" quand B1 est vide.
Messages postés
45
Date d'inscription
samedi 25 avril 2009
Statut
Membre
Dernière intervention
27 juin 2021

Re,

Autant pour moi j'avais décalé une ligne.
Effectivement il n'y a que si B1 est vide que cela pose un petit soucis (affichage "VRAI") mais ça ira parfaitement.

Un grand MERCI à tous les deux !
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
6 136
Re en complément pour afficher FAUX si B1 est vide:
=SI(OU(ESTVIDE(B1);NB.SI($A1:$A1;"*"&$B$1&"*")=0);FAUX;VRAI)
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
45
Date d'inscription
samedi 25 avril 2009
Statut
Membre
Dernière intervention
27 juin 2021

Merci de la réponse,

En gros, je voudrais que si en B1 on écrit

- exactement l'une des valeurs de l'une des cellules de la liste (ex : "Camion blanc")
ou
- une partie de l'une des valeurs de l'une des cellules de la liste (ex : "Camion")

Alors en C1 on me mette "VRAI", sinon "FAUX".
Messages postés
45
Date d'inscription
samedi 25 avril 2009
Statut
Membre
Dernière intervention
27 juin 2021

J'avais cette formule (à mettre en C1):
=SI(NB.SI(A1:A3;B1)>0;"VRAI";"FAUX")

Mais le problème c'est que C1 n'affichera "VRAI" que si B1 est égal à la valeur exacte de la liste.

Et moi je voudrais que ça affiche "VRAI" même si B1 n'est égal qu'à une partie de l'une des valeurs (ex: "Camion" au lieu de "Camion blanc").

Je ne sais pas si c'est plus clair !

Encore merci !