Actualisation tableau par changement de date [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
16 juin 2014
-
Messages postés
19
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
16 juin 2014
-
Bonjour à tous,

J'ai un journal qui enregistre chrolologiquement les opérations et se cumul sur plusieurs années. J'ai dans une autre feuille un tableau synthèse des opérations mensuelles consolidées par type de produit.
Une cellule contient une date de réference de l'année.
Comment faire qu'à partir du changement de cette date que j'obtienne les données de l'année voulu?
Exemple:
Feuile1: ColonA : Date: de 1/1/2010 .... 31/1/2010 , 1/1/2011 ...1/8/2011
Feuil2:
D5: 1/1/2010 au format (yyyy)
De C7 à C18 les mois de janvier à decembre au format (mmm)
c7= date(année(D5),mois(d5),1) (Format (mmm)), C8= date(année(c7),mois(c7)+1,1)
et ainsi de suite.
Je souhaite, en modifiant la cellule D5, que mon tableau ne me recupère que les données de l'année indiquée.
Avec l'année 2010 cela ne pose pas de problème mais, mes ennnuis commencent quant je change D5=1/1/2011, la cellule affiche 1905 au lieu de 2011 et le tableau se renverse (ordre) et affiche les mois de juillet à juin.
Quelques pistes SVP!

Merci d'avance de votre assistance et de toutes vos suggestions,
Aussi merci à ce Forum!
Crdlmt





3 réponses

Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bonsoir
çà ne semble pas anormal si vous placez "ANNEE(D5) dans la formule et 2011 en D5, car excel vous renvoi alors l'année du 2011° jour de son calendrier soit 1905
Placez simplement D5 au lieu de ANNEE D5 ou alors entrez en D5 une date complète telle que 1/1/2011
Sauf erreur!
crdlmnt
Messages postés
19
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
16 juin 2014

Bonjour,
Merci à vous Vaucluse, très pragmatique et très prompt à mon assisstance.
Vous avez raison sur la manière d'entrer la date en D5; mais est il que le problème demeure. Je n'arrive pas à recuperer les données voulues, c'est à dire les données de 2011, puisque seule l'année change.
Faudrait il ajouter et comment le faire, un paramètre dans la formule suivante
=sommeprod((mois(a1:a100)=1)*(b1:b100="ref")*...*(e1:e100)) pour tenir compte du changement de l'année? Puisque = 1 representant le mois de janvier par exemple reste indifferent du changement de l'année.
Merci
crdlmt
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bonjourt
=SOMMEPROD((ANNEE(Champ)=$D$5)*(MOIS(Champ)=1)*(E1:E100)) devrait résoudre le problème si vous entrez en D5:
1/1/ 2011 (n'importe quel jour pourvu que l'année y soit)
les données changeront d'années dès que vous entrez en D5 une date incluant l'année cherchée
crdlmnt
Messages postés
19
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
16 juin 2014

Bonsoir,
sincèrement grand merci à vous du partage de votre savoir et pour l'aide apportée.
ça marche.
A +
Crdlmt