Excel : Suppression de ligne sous condition

Résolu/Fermé
freygeo
Messages postés
20
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
14 mars 2013
- 13 déc. 2010 à 11:40
michel_m
Messages postés
16568
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 mai 2022
- 13 déc. 2010 à 12:11
bonjour tout le monde,

Le petit problème du lundi matin est arrivé...

J'ai un tableau de 3 colonnes. Une formule me permet grâce à la colonne B de remplir la colonne A

La colonne A de temps en temps ne trouve pas de référent dans la colonne B et donc affiche la valeur "#N/A" ce qui est normal

Je voudrais simplement créer une macro qui supprime toute les lignes où la valeur de la colonne A vaut "#N/A"

d'avance merci...

ps : mon tableau contient 65536 lignes
A voir également:

3 réponses

Bidouilleu_R
Messages postés
1181
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
12 juillet 2012
272
13 déc. 2010 à 11:56
Bonjour,
d'accord avec Pilas31,

un exemple
la "base" est en A3:B10
le critère de recherche en C3...Cxx et la formule en D3 Dxx
c'est un exemple!

=SI(ESTNA(RECHERCHEV(C3;$A$3:$B$10;2;FAUX));"";RECHERCHEV(C3;$A$3:$B$10;2;FAUX))
1