Excel : Suppression de ligne sous condition [Résolu/Fermé]

Signaler
Messages postés
20
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
14 mars 2013
-
Messages postés
16214
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 septembre 2020
-
bonjour tout le monde,

Le petit problème du lundi matin est arrivé...

J'ai un tableau de 3 colonnes. Une formule me permet grâce à la colonne B de remplir la colonne A

La colonne A de temps en temps ne trouve pas de référent dans la colonne B et donc affiche la valeur "#N/A" ce qui est normal

Je voudrais simplement créer une macro qui supprime toute les lignes où la valeur de la colonne A vaut "#N/A"

d'avance merci...

ps : mon tableau contient 65536 lignes

3 réponses

Messages postés
1181
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
12 juillet 2012
252
Bonjour,
d'accord avec Pilas31,

un exemple
la "base" est en A3:B10
le critère de recherche en C3...Cxx et la formule en D3 Dxx
c'est un exemple!

=SI(ESTNA(RECHERCHEV(C3;$A$3:$B$10;2;FAUX));"";RECHERCHEV(C3;$A$3:$B$10;2;FAUX))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
16214
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 septembre 2020
3 036
Bonjour à tous

quelque soit la gestion de l'erreur (si erreur==>""), il faudra toujours gérer son résultat pour supprimer la ligne incriminée, donc on laisse les #NA

la macro en 1 ligne (supprime toutes les indications d'erreur; na,erreur, nom?...):

Columns("A").SpecialCells(xlCellTypeFormulas, 16).EntireRow.Delete

Michel
Vous programmez en VBA pour Excel? Pensez D'ABORD en EXCEL avant de penser en VBA...(P. Fauconnier/dvp)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
584
Bonjour,

Peut-être suffit-il de modifier la formule des cellules de la colonne A pour éviter le cas en erreur ?
Pourrait-on voir cette formule ?

A+