Samba integré à un domaine windows

Fermé
bakou - 9 déc. 2010 à 14:38
 bakou - 9 déc. 2010 à 15:13
Bonjour, je dispose d'un poste debian avec squid et samba installé, un 2008 serveur avec un poste client xp membre du domaine windows. j'ai donc configurer mon debian pour l'intégré au domaine en plus de cela j'utilise squid comme proxy qui se base sur les authentification active directory. je souhaite partager avec samba des fichier. j'ai donc configuré samba et squid mais aussi kerberos quand je vais sur mon xp je me connecte avec la session d'un utilisateur autorisé dans samba j'accède a ma machine debian dans le favorie réseau je vois bien mes deux dossier partagés + le dossier personnel de mon utilisateur connecté sauf que quand je veut accéder a l'interieur du dossier il me demande un mot de passe avec un nom d'utilisateur je tape donc l'identifiant avec son mot de passe et la rien ne se passe j'ai beau cliquer 300 fois rien ne bouje aucun message d'erreur aucune action la fenêtre d'identification reste inerte.

j'ai executer les commande "kinit" et "net ads join" aucun message d'erreur samaba connait mes utilisateur active directory ils sont autorisé à l'aide de "smbpasswd"

serveur 2008 : 192.168.2.201
debian: 192.168.2.25
domaine: D2201.loc

smb.conf:

[global]
workgroup = D2201
netbios name = %h
server string = %h %v
map to guest = Bad User
os level = 65
domain master = no
local master = yes
realm = D2201.LOC
security = ADS
password server = 192.168.2.201
client use spnego = yes
client ntlmv2 auth = yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
announce version = 4
announce as = NT Workstation
dns proxy = No
idmap uid = 167771-335549
idmap gid = 167771-335549
winbind enum groups = yes
winbind enum users = yes
winbind use default domain = Yes
invalid users = root


[administration]
comment = doc admin
path = /home/administration
valid users = megane,marine
public = no
writeable = yes


[personnel]
comment = doc perso
path = /home/personnel
valid users = martine,gerard
public = no
writeable = yes

merci =)


1 réponse

zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 569
9 déc. 2010 à 14:43
Salut,

Il faut que tu rajoutes ton user Windows dans Samba via la commande "smbpasswd -a user".

Voir ce thread qui date un peu mais qui devrait t'aider ;-))
0
j'ai marqué que je l'avais déja fait merci quand même mais y-a t-il d'autres solutions, :)
0
zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 569
9 déc. 2010 à 15:08
Oups désolé, j'avais zappé ce passage ;-(
0
une précision j'ai aussi appris que l'authentification unix ne gere pas la casse ni les chiffres j'ai donc mis des mot de passe azerty aux util samba et windows donc la je bloque tout les tests marche quand je veux acceder riuen ne se passe!
0