Aide pour excel ou open office [Fermé]

Signaler
-
 Mixit -
Bonjour,

J'ai besoin de votre aide pour réaliser un tableau excel ou calc.

J'ai 2 colonnes A et B.
Ce que je voudrais c'est qu'à chaque fois que je remplis la celluleA par un chiffre (ex:34), la cellule B se remplisse par une référence bien précise (par ex:1204 ou un texte de mon choix)

Faut-il faire une macro? Je ne sais pas comment procéder.

Merci d'avance pour votre aide.



2 réponses

Messages postés
154
Date d'inscription
jeudi 3 janvier 2002
Statut
Membre
Dernière intervention
30 septembre 2010
23
Excel: Il faut utiliser la fonction RECHERCHEH(), et créer un tableau représentant les couples de valeur quelque part dans ton classeur.

Par exemple, je créé un tableau comme ceci:

34 tutu
37 titi
39 tata

Les nombres sont en H1,H2 et H3, les mots en G1,G2 et G3

En B1, je mets cette formule:

=RECHERCHEV(A1,G1:H3,2)

Quand je tapes 34 en A1, j'obtiens tutu en B1.
Si je mets 37 en A1, j'obtiens titi en B1 etc...
Messages postés
52467
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
14 340
sushicat a voulu donner une réponse immédiate, ne s'est pas relu avec assez de vigilance et a laissé passer quelques erreurs de frappe :

1°) "Il faut utiliser la fonction RECHERCHEH()" : en fait c'est RECHERCHEV(), comme on le constate ensuite ...

2°) malencontreuse inversion de lettres : Les nombres sont en H1,H2 et H3, les mots en G1,G2 et G3 alors qu'il fallait écrire Les nombres sont en G1,G2 et G3, les mots en H1,H2 et H3.

3°) Normalement, la syntaxe de la fonction, dans Excel version en français, utilise des points-virgules, pas des virgules simples : =RECHERCHEV(A1 , G1:H3 , 2) doit s'écrire =RECHERCHEV(A1 ; G1:H3 ; 2)

Par ailleurs il est prudent de compléter la formule de sushicat pour le cas où les données de la colonne A ne seraient pas triées dans l'ordre croissant :
=RECHERCHEV(A1;G1:H3;2) doit devenir =RECHERCHEV(A1;G1:H3;2;FAUX)

Et si cette formule est destinée à être recopiée vers le bas, il faut "fixer" la plage de recherche pour qu'elle ne devienne pas successivement G2:H4, G3:H5 etc. ; pour y parvenir, écrire =RECHERCHEV(A1;$G$1:$H$3;2;FAUX)

Et avec cela, ça devrait marcher au poil !
Messages postés
154
Date d'inscription
jeudi 3 janvier 2002
Statut
Membre
Dernière intervention
30 septembre 2010
23
Effectivement, malencontreuse erreur entre rechercheh et recherchev, mes doigts ont fourché.
Pareil pour les colonnes, je commence à me demander si je ne suis pas dyslexique.

Pour les virgules et point-virgules, le problème vient de ma config qui est en anglais US car je bosse avec l'étranger, mais avec des points-virgules c'est vrai que c'est beaucoup mieux :)

Merci pour les corrections.
Messages postés
52467
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
14 340
Je t'en prie !
Espérons surtout que Mixit en sera satisfait ...
Je n'ai pas encore essayé mais je vous tiendrai au courant.
Merci beaucoup votre rapidité de réponse.
Et merci à Sushicat pour la rectification
Mille Mercis à vous 2!!
Cela fonctionne parfaitement!
Vous allez me faciliter la vie!
Vous êtes géniaux!