Mails cryptés

Résolu/Fermé
-
 alex13260 -
Bonjour à vous tous,
Petit soucis avec mes mails.
Je suis donc sur Mac et lorsque j'envoie des mails à certains clients qui sont eux sur Pc,
ces dernières les reçoivent cryptés.
Pourquoi cela ne le fait pas à tout le monde?
Et surtout comment faire, pour les décrypter?
Je pense que la manip doit se faire de leur PC et non à partir du Mac...
Je ne suis pas suis Entourage mais sur Mail
Merci d'avance et viiiiiiiiiiiiiiiite car je galère trop.
Garance

2 réponses

Messages postés
26909
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
19 décembre 2021
5 384
Bonsoir,

"Viiiiiiiiiiite" est mort mais il a envoyé un message particulier avant de disparaître, à l'attention, et à l'intention des gens pressés.
"Rien ne sert de courir, il suffit d'arriver."

[ Henri Dreysse ]
Cher Dédé,
je pensais que tu pourrai m'aider mais en fait il en est rien...
je suis désolée d'avoir employée le mot "vite" mais je ne pensais pas non plus que cela attirer des remarques!!!
Si tu as une réponse pour mon problème ce serait cool...
Messages postés
26909
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
19 décembre 2021
5 384
regarde ici à tout hasard !
Que nini mais j'ai quand même gardé cette page sous le coude!!!
Messages postés
565
Date d'inscription
samedi 2 janvier 2010
Statut
Contributeur
Dernière intervention
31 décembre 2010
217
Garance :
Je suis donc sur Mac et lorsque j'envoie des mails à certains clients qui sont eux sur Pc,
ces dernières les reçoivent cryptés.


Cela mériterait quelques précisions complémentaires. En particulier, quelle est la version de Mail ? tes messages sont-ils en texte brut ou en RTF ? contiennent-ils des pièces jointes ? etc.

Sinon, c'est un sujet qui a déjà été largement débattu et c'était même un grand classique du temps de Tiger (ça s'est un peu arrangé avec la version de Leopard) : Mail tend à encoder comme un cochon dès qu'il y a une pièce jointe. Pour contourner le problème, il faut forcer l'encodage en UTF-8 avant l'envoi. Pour mettre ce réglage par défaut il faut (après avoir quitté Mail) taper dans le Terminal la commade suivante :
defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

Avec la version Leopard, les choses se sont donc un peu amélioré, mais il faut mettre les pièces jointes tout à la fin du message (aucun texte après), si je me souviens bien...


Garance :
Je ne suis pas suis Entourage mais sur Mail


Ben oui, on s'en doute, tu utiliserais Entourage (ou Thunderbird) tu n'aurais pas ce problème. ;-)


Bonjour chez vous !
Bernard
Bernarrrrd!
Je suis une bille comme tu l'as pu le constater.
Peux-tu donc me dire comment je fais cette manip?
Merciiiiii d'avance cher Bernard!!
Bernaaaaaaaaaaaaaaaaaaaard c'est bon j'ai trouvé......
Merci d'avoir pris le temps de me répondre.
Garance
Messages postés
565
Date d'inscription
samedi 2 janvier 2010
Statut
Contributeur
Dernière intervention
31 décembre 2010
217
Oui, pour l'encodage au coup par coup, j'aurais pu préciser : une fois le message terminé, il faut aller dans le menu "Message" > "Encodage du texte" > "Unicode (UTF-8)".

Mais c'est vite fastidieux, la modification du réglage par défaut via le Terminal est un peu plus confortable. Mais précise tout de même un peu le contexte, pour être sûr que ça s'applique bien dans ton cas...
Je suis graphiste et j'envoie donc des maquettes en pièce jointe.
Mais dans certains cas, les gens les reçoivent avec plein de caractères.
J'ai donc testé ce que tu m'as dit et je verrai si la cliente le reçoit bien...
Si problème je te renverrai un mail.
En tout cas un grand MERCI
Messages postés
39184
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
20 janvier 2022
11 383
Bonjour,

De manière générale, lorsque on ne connaît pas le logiciel de messagerie utilisé par le destinataire, il vaut toujours mieux envoyer ses messages en texte brut et non en RTF. (choix dans les Préférences de Mail).

Mais ce réglage ne joue pas sur la lisibilité des pièces jointes.
Pour ces dernières,
- il faut penser à cocher l'item "Toujours envoyer des pièces jointes compatibles Windows" dans le menu Edition / Pièces jointes...
- et surtout demander au destinataire de recevoir son courrier dans un logiciel de messagerie et non dans une page webmail depuis un navigateur web.

La plupart du temps, le problème vient de ce dernier point.
Faites l'expérience en vous envoyant à vous même des photos de taille conséquente. Vous les recevrez correctement dans votre logiciel de messagerie, alors qu'elles seront présentées comme un fichier rempli de caractères ou signes quelconques dans une page webmail. Le site de Laposte et probablement le pire dans ce domaine.

Et cela que vous soyez sous Mail, Entourage, Thunderbird ou autre. J'ai testé tous les cas de figure. Mail ne fait pas pire que les autres dans ce cas. (clin d'oeil à Bernard). Et personnellement je ne trouve pas que Mail encode plus mal que les autres non plus. (re-clin d'oeil à Bernard).

Bonne Soirée.