Probleme d'integration menu avec css

Résolu/Fermé
Signaler
-
 louseb84 -
Bonjour,
mon probleme est le suivant.
mes lien de mon menu sous forme de liste ne fonctionne plus une foi integrer dans mon <div> "maincontent" a redimensionnement auto (ni la main ni le a:hover et encore moins la redirection) alors qu'il fonctionnait parfaitement sur ma page teste. ce n'est pas un probleme de chemin d'acces...

un bout de code vaut mieux qu'un long discourt alors voici le html correspondant a mon maincontent.


<div class="maincontent">
<div class="sous_menu">

<ul class="sous_menu">
<li><a href="galerie" title="">Galeries photos</a></li>
<li><a href="derniere_realisation" title="">Dernières réalisations</a></li>
<li><a href="acces_prive" title="">Accès privés</a></li>
</ul>
</div>

<div class="picsengine">
je vous epargne le code d'integration flash du logiciel diapo
</div>
</div>


et le css correspondant

.maincontent{
width:20% 80%;
}

.sous_menu{
padding-left:50px;
padding-top:100px
}

ul.sous_menu{
width:20%;
height:100%;
padding:0;
list-style-type:none;
}

ul.sous_menu a{
text-align:left;
text-decoration:none;
padding:3px 14px;
font-family:Geneva, Arial, Helvetica, sans-serif;
font-size:14px;
}

ul.sous_menu a:hover
{
color:#000000;
}

.picsengine {
padding-left:20%;
width: 80%;
position:absolute;
top: 75px;
bottom: 60px;
}


merci a toute personne qui pourait m'aider
sebastien


2 réponses

Messages postés
3255
Date d'inscription
jeudi 27 décembre 2007
Statut
Membre
Dernière intervention
8 février 2020
618
Bonjour,

J'ai tester ton code chez moi, et il marche.

Donc verifie que d'une part les fichiers galerie; derniere_realisation et acces_prive sont bien dans au même endroit que ton fichier qui les appele, et d'autre part dit moi si ces fichier n'ont pas d'extension ou bien tu as juste oublié de mettre le .html a la fin de chacun (ce qui pourrait être la cause de l'erreur.
salut et merci de ta reponse.

mais chemin d'acces sont tous bon, de la ne venait pas le probleme. les pages ne sont pas encore creer d'ou l'absence d'extension.

je m'en suis apercu en appliquant un "border : 1px dashed black;" sur mon bloc "picsengine" qui ma fait remarquer que malgrer le fait que mon wiever (picsengine) occuper bien 80% de la droite de ma page, mon bloc quand a lui occuper 100% puisque j'ai utiliser un "padding-left: 20% pour le positionner.
il passait donc au premier plant par rapport a mon menu ce qui m'empecher de pouvoir clicke sur mes lien....!!!

je viens juste de trouver la solution. j'ai seulement remplacer mon padding-left: 20%; dans ".picsengine" par un right:0px; toujours en position absolut.

merci quand meme de t'etre pencher sur le probleme
sebastien