Ds un tableau compter le nb de dates en janv [Résolu/Fermé]

Signaler
-
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010
-
Bonjour,
Dans un tableau rempli de dates au format jj.mm.aa, je voudrais compter le nb de dates du mois de janvier/février,...
Merci d'avance.

J'ai lu dans une réponse qu'une fois qu'on a reçu la solution, il faut mettre le message sous résolu. Comment on fait?


17 réponses

Messages postés
17408
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 juillet 2021
4 668
Salut,

Avec quel logiciel !

sur excel
=SOMMEPROD((MOIS($B$2:$B$100)=1)*1*($B$2:$B$100<>"") )
ensuite, remplace le =1 par =2 pour février, etc...

éventuellement en D1 créer une liste déroulante
=SOMMEPROD((MOIS($B$2:$B$100)=D1)*1*($B$2:$B$100<>"") )
Messages postés
17156
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
10 489
Bonjour,
Pour mettre le message en Résolu, il faut être enregistré, ce que bien sûr on te conseille de faire, car c'est plus convivial...
Messages postés
54288
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
16 269
En supposant que tu es sous Excel, sélectionne la plage de cellules concernées et regarde les statistiques dans la barre d'état, tout en bas de l'écran ; s'il manque certaines fonctions, tu fais clic droit dans la barre et tu ajoutes celles que tu souhaites.
Messages postés
17156
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
10 489
Bonsoir,

Y a juste un truc qui m'interpelle dans le post de thunderesse... C'est le format jj.mm.aa qui n'est pas un format date Excel.... Cela dit c'est peut être une erreur...

m@rina
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
875
Salut le forum

Première tentative avec une matricielle.

Si le tableau ne contient pas de cellule vide et le
séparateur de date est bien le point (jj.mm.aa)

La formule pour Janvier, formule matricielle à valider par Ctrl+Shift+Enter

=SOMME(SI(CNUM(STXT(A1:A10;4;2))=1;1;0))

Mytå
Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
Désolée mais je n'y suis pas arrivée avec vos propostiotions

J'ai finalement trouvé une formule qui a l'air de fonctionner

=NB.SI($J$2:$R$164;">=01.01.10") -NB.SI($J$2:$R$164;">=01.02.10")
pour janvier.

=NB.SI($J$2:$R$164;">=01.02.10") -NB.SI($J$2:$R$164;">=01.03.10")
pour février et ainsi de suite...

Merci pour votre aide
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
875
Re le forum

Thunderesse, tes dates sont des vraies dates ou un format texte ?

Mytå
Tout d'abord, merci pour ton aide...

Je suis méga débutante sur excel avec zéro cours d'informatique à mon actif. Tout ce que je sais faire c'est lire sur internet des solutions à mes problèmes et de les appliquer plus ou moins. Alors je ne sais pas si mes dates sont des vraies dates ou du texte.

Si je clique sur Format de la cellule, je suis dans la Catégorie: date, Type: 14.03.01
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
875
Re le forum

Pour les mois de Janvier sans tenir compte de l'année
=SOMMEPROD((MOIS($J$2:$R$164)=1)*($J$2:$R$164<>""))

Pour les mois de Janvier en tenant compte de l'année
=SOMMEPROD((ANNEE($J$2:$R$164)=2010)*(MOIS($J$2:$R$164)=1)*($J$2:$R$164<>""))

Mytå
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010

Si je mets une des deux formules, J'obtiens :#VALEUR!
Messages postés
17156
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
10 489
Bonjour Thunderesse

Effectivement ces formules ne peuvent pas fonctionner si tu n'a pas un format date.

Dans un premier temps, tu vas remplacer tes points par des /, ce qui va transformer tes pseudo dates en vraies dates reconnues par Excel. Pour cela :
- Sélection de ta colonne Date
- Edition => Remplacer
- Rechercher : .
- Remplacer par : /
- Remplacer tout

Ensuite, réessaie les formules qui, cette fois, devraient fonctionner à coup sûr !

m@rina
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010

Est-ce que ça change si je suis sur MAC??? Car ça ne marche pas :-( Pourtant remplacer, c'est qch que je sais faire... Mais ça ne remplace rien du tout bien qu'il soit marqué qu'il y a 1045 remplacements...
Messages postés
17156
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
10 489
Tu me fais peur !
1045 remplacements ? et tu ne vois rien...

Bon, tu vas enregistrer ton fichier sous un nouveau nom pour ne pas détériorer l'original.
Fais une copie de l'original et travaille avec cette copie.

Quand on fait un remplacement, il faut sélectionner avant car tu risques effectivement de remplacer partout, et pas forcément où il faut.

Je ne sais pas si, sous Mac, les points peuvent servir aux dates... Prends une date avec des points, va dans le menu Format, cellule, Nombre, et mets un format date toutes lettres (jj jjjj mmmm aaaa). Si tu vois s'afficher une date, c'est OK, si ça ne change rien, c'est que ce n'est pas une date pour Excel. Dans ce cas, remplacer les points par des /.

Et surtout, je me répète, travaille sur une copie !

m@rina
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010

oui ça m'écrit une date 03.03.10 devient 3 mars 2010
mais alors pourquoi la formule proposée par Myta ne fonctionne pas...???

Ne t'en fait pas je travaille sur une copie... Si je perds ce fichier... c'est pas ma mort mais tout comme... ;-)
Messages postés
17156
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
10 489
Donc, les choses sont différentes sur Mac!

Les formules de Myta sont tout à fait correctes, mais peut être ne fonctionnent elles pas sur Mac...
Tu as un Excel français ?

m@rina
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010

Oui mon excel est en français...
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
875
Re le forum

Que te retourne la formule suivante : =MOIS(J2)

Remplace J2 par une cellule qui contient une date

Ta plage J2:R164 ne contient bien que des dates, tu n'as aucune valeur texte

Mytå
Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
Messages postés
10
Date d'inscription
samedi 7 août 2010
Statut
Membre
Dernière intervention
7 août 2010

ok j'ai trouvé le problème, certaine de mes case vides n'étaient pas vraiment vides mais ="" alors maintenant ça marche

Merci