EXCEL 2003 SOMME

Résolu/Fermé
Flo - 21 juil. 2010 à 10:15
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
- 21 juil. 2010 à 14:43
Bonjour,

J'ai un tableau avec 2 colonnes:

Colonne 1: Article (par ex: 222 en A1 jusqu'à A5, 225 en A6 jusqu'à A12, 203 en A13 jusqu'à A20 etc.)

Colonne 2: Quantité (par ex: B1=2, B2=3, B3=1 etc)

J'aimerais faire la somme des quantités par article et pour tout les articles.

2 réponses

pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 694
Modifié par pijaku le 21/07/2010 à 10:33
Bonjour,
Soit :
- en colonne A tes références
- en colonne B tes quantités
En C1, indique la référence recherchée (tu peux même, si tu veux, y placer une liste déroulante de tes références)
2 choix maintenant :
- ta plage est fixe de A1 à B53 (par exemple) :
en D1 : =SOMMEPROD((A1:A53=C1)*(B1:B53))
- ta plage n'est pas fixe et peux évoluer au fil de tes saisies :
en D1 : =SOMME.SI(A1:DECALER(A1;NBVAL(A:A);0;;);C1;(B1:DECALER(B1;NBVAL(B:B);0;;)))
Cordialement,
-- Tout problème à sa solution. S'il n'y a pas de solution, ou est le problème? --
0
Merci pijaku,

ton 1er choix m'interresse, mais au lieu de refaire une colonne C avec toutes mes réferences, je peux pas faire plustôt:

C1: =SOMMEPROD((A1:A53=A1)*(B1:B53)) ?
0
ensuite C2: =SOMMEPROD((A1:A53=A4)*(B1:B53))

Il y aurait pas un moyen de faire tout ca en 1 ligne de code?
0
une ligne qui définit la chose suivante:

"faire la somme des articles=A2 et faire la somme des articles +grand ou + petit que A2"
Dans ce cas je ferais une colonne C avec toutes mes réf.
0
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 694
21 juil. 2010 à 11:15
Tu peux faire quelque chose comme :
en C1 : =SOMMEPROD(($A$1:$A$20=A1)*($B$1:$B$20))
en C2 : =SI(A2=A1;"";SOMMEPROD(($A$1:$A$20=A2)*($B$1:$B$20)))
et tu étires la formule de C2 vers le bas...
0
Merci je m'approche de plus en plus, malheureusement j'ai un 3eme colonne (Avec un Lieu), je doit entrer le total de chaque articles pour tout les articles mais par Lieu. Ca devient interressant :-)
0
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 694
Modifié par pijaku le 21/07/2010 à 12:17
Il "suffit" d'ajouter ta 3ème condition :
en C1 : =SOMMEPROD(($A$1:$A$20=A1)*($B$1:$B$20)*($C$1:$C$20="toulouse"))
en C2 : =SI(A2=A1;"";SOMMEPROD(($A$1:$A$20=A2)*($B$1:$B$20)*($C$1:$C$20="toulouse")))
0