Affecter 1 nbr aux choix multiples d1 cellule [Résolu/Fermé]

Signaler
-
 moi -
Bonjour,

J'ai créer un cellule (A1) avec choix multiple : triangle, uniforme, gauss et je souhaite faire varier
le coefficient de la case d'à coté (B1) suivant la fonction choisie.
Par exemple je veux que si on choisit pour A1 triangle, B1=2; si A1=unifome,B1=3 ect...

Merci d'avance

2 réponses

Messages postés
26112
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 juillet 2021
5 995
Bonjour
tout simplement:
=SI(A1="triangle";2;SI(A1="uniforme";3;SI(A1="gauss";4)))
si toutefois vous êtes sous excel 2003,la limite de SI est de 7.
vous pouvez alors passer par une autre solution selon cet exemple à adapter:
de X1 à X10 la liste de vos références à placer en A elle vous sert de base pour la validation en A
de Y1à Y10 les valeurs de B correspondantes à chaque code
en B1:
=SI(ESTVIDE(A1);"";RECHERCHEV(A1;$X$1:$Y$10;2;0)
Crdlmnt
Super pratique merci, ça fonctionne parfaitement
Merci bcp, reponse simple et efficace!!! J'ai pris des cours d'informatique mais je viens de découvrir que les formules de base en C étaient applicables en bureautique!^^
Bonne jounée