Fonction double si, resultat VALEUR # [Résolu/Fermé]

Signaler
-
 Nomi -
Bonjour,

je sais que c'est simple en soi, mais je dois beuguer sur la syntaxe...

Situation :
dans mon tableau de suivi, je souhaite un formule qui me sorte " ALERTE" si le délai de traitement est supérieur à la normale.

Disons,
en col A : le délai "normal"
en col B : la date de reception du client
en col C : ma forule.

j'obtiens qqch du genre :
=SI(b2="";"");SI(AUJOURDHUI()-B2>A2;"ALERTE";"")

ET quand je valide, ça me met : VALEUR#

Je sais pas si ça du format de ma cellule (standard) ou d'une erreur de syntaxe...

Pourriez-vous éclairer ma lanterne ????

3 réponses

Messages postés
1488
Date d'inscription
mercredi 18 février 2009
Statut
Membre
Dernière intervention
23 août 2010
269
tu ferme la parenthèse du premier SI trop tot, et tu n'as pas besoin de double guillemets pour tester une égalité avec un point-virgule

essaye
=SI(b2=";";SI(AUJOURDHUI()-B2>A2;"ALERTE";""))

cela se traduit par

Si B2 est un point virgule, alors si le test de date est vrai, je fais alerte, sinon rien, sinon rien

est-ce bien ca que tu voulais faire?
pas exactement,
je souahite traduire cette phrase :
si il n'ya pas de date dans la cellule B1, alors ne rien mettre sinon si, le délai entre aujourd'hui et la date de réception est supérieur au délai normal (cellule A1) alors je veux ALERTE, sinon rien
Bonjour,

Je pense que Nomi ne voulait pas tester si b2 était = à un point virgule mais si b2 était vide.
Ce qui ferait plutôt
=si(b2="";"";si(aujourdhui()-b2>a2;"alerte"))

Cyn
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 275
J'ajouterais même que l'on pourrait remplacer B2="" par ESTVIDE(B2).

Cordialement.
Messages postés
1488
Date d'inscription
mercredi 18 février 2009
Statut
Membre
Dernière intervention
23 août 2010
269
hum, pas bete :) :) et ca parait plus logique d'un coup
merciiiiiiiiiii cyn16, ça marche.
mon souci était bien du à la syntaxe : une parenthèse qui trainait !!

gracias